summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 12:03:08 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 12:42:51 +0200
commiteca8db92aabbb1e0859738cebbc0735471cc53db (patch)
treeb55fee0d7fe1c29d8d601d90f02ad3d008f09baf
parentapp-office/gnumeric: Drop old (diff)
downloadgentoo-eca8db92.tar.gz
gentoo-eca8db92.tar.bz2
gentoo-eca8db92.zip
app-office/gnumeric: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.31.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 661fd90dd30c..45dc7a026389 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.29.tar.xz 18738564 SHA256 5a35c56679027e5d0e61f67358c2feee458dc0f62494e32281c9a1a579ba7fb5 SHA512 342e0349e251240aaa916fde6eb69ee7588070d979434211b8fd54c6065db33f7148c1c40a954736ef9a7d0271a034f9cee5b66df81abd527504ade678591162 WHIRLPOOL b9541480207ea4175e1b92e75724adfc9bba3530a5b5d63e46d65673a9ab4b03fa900c109722e51df442ec10fac5c27e60d2705b95e163c870296a784da19762
+DIST gnumeric-1.12.31.tar.xz 18742540 SHA256 c8ace78e75c280dced3f15b27c44c7a98e8d21cd8361c6b2599cce191f6d6ae7 SHA512 e6d6cef034517015fffc2938e69f1b9e47f12ad7ae5fc6fcf7c5d95bda06d37c234048c2621fda8f2576a811b20698aea8a3313d020c1bceb8337f66f8d41fb6 WHIRLPOOL 442f31e38e55c901a838b9d58352c309f69077498829b8179643e4d9eb1d2f47de454cead4cee5c04c7de3ff50ad7d85606d65263703a2a47afabfbc1216405b
diff --git a/app-office/gnumeric/gnumeric-1.12.31.ebuild b/app-office/gnumeric/gnumeric-1.12.31.ebuild
new file mode 100644
index 000000000000..ba3a957eac68
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.31.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.28:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}