summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-02 07:57:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-02 08:04:17 +0100
commitecbbfac71e5c8a48386599aeccd8eae2f906aa3c (patch)
tree889ad47796a62588ce2678c7d893e19991c05048
parentdev-python/alembic: Bump to 1.13.0 (diff)
downloadgentoo-ecbbfac71e5c8a48386599aeccd8eae2f906aa3c.tar.gz
gentoo-ecbbfac71e5c8a48386599aeccd8eae2f906aa3c.tar.bz2
gentoo-ecbbfac71e5c8a48386599aeccd8eae2f906aa3c.zip
dev-python/starlette: Bump to 0.33.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.33.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 497ee3426b58..da9eff7eeca9 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1 +1,2 @@
DIST starlette-0.32.0.gh.tar.gz 2839571 BLAKE2B adf6b382b267f77309cea1914e980df3ec6e1a05c2ed535c9a26518581349523f9ef5b07c3b97af9123950a52b4ea43acd257527e00a83423b992ce93956b86e SHA512 4b655af29e0a2e031db4155e8697d23abee1e100735904a47b0989faf56a9a05c007a672e6576748849347aaab931c8c1ea89a09d77b04ac8b55a78284ab551a
+DIST starlette-0.33.0.gh.tar.gz 2840495 BLAKE2B 64bf929409be913bd193d0a929c7ab158383ea69a31a98833f425d68f308a1459998af89b631c6db34a32ef599e10fa0dd11c07c7d74e90de2ff10d2a7378a46 SHA512 4ebf75b76656a23599e45b839451af13261ac893efd4dcb3fb1a23de79e9779e8a1e007e3f8d755228f8348aa3e7d821e885774a8fd04a1efac45776cf00790f
diff --git a/dev-python/starlette/starlette-0.33.0.ebuild b/dev-python/starlette/starlette-0.33.0.ebuild
new file mode 100644
index 000000000000..5157f33105ee
--- /dev/null
+++ b/dev-python/starlette/starlette-0.33.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest