summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-29 18:16:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-29 18:18:25 +0100
commitecc988102fa750dcf2401eaf2c295a31d97a0d20 (patch)
tree8848ff3f0354b402e1dbb446ad425f1933c52112
parentdev-python/terminado: Add missing dev-python/pytest-timeout dep (diff)
downloadgentoo-ecc98810.tar.gz
gentoo-ecc98810.tar.bz2
gentoo-ecc98810.zip
dev-python/simpervisor: Add a fix for newer yarl compatibility
Closes: https://bugs.gentoo.org/923234 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch28
-rw-r--r--dev-python/simpervisor/simpervisor-1.0.0-r1.ebuild (renamed from dev-python/simpervisor/simpervisor-1.0.0.ebuild)7
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch b/dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch
new file mode 100644
index 000000000000..5f884255262c
--- /dev/null
+++ b/dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch
@@ -0,0 +1,28 @@
+From b08f4b9b46009fb96c7194aecbc28d6b266e44c0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 29 Jan 2024 18:14:32 +0100
+Subject: [PATCH] Convert `PORT` envvar to int to fix aiohttp/yarl
+ compatibility
+
+Conver the value of the `PORT` environment variable to int, to fix
+incompatibility with modern versions of aiohttp/yarl, that do expect
+the `port` argument to be one.
+
+Fixes #49
+---
+ tests/child_scripts/simplehttpserver.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/child_scripts/simplehttpserver.py b/tests/child_scripts/simplehttpserver.py
+index cc460ff..268dc7d 100644
+--- a/tests/child_scripts/simplehttpserver.py
++++ b/tests/child_scripts/simplehttpserver.py
+@@ -11,7 +11,7 @@
+ print("waiting", wait_time)
+ time.sleep(wait_time)
+
+-PORT = os.environ["PORT"]
++PORT = int(os.environ["PORT"])
+
+ routes = web.RouteTableDef()
+
diff --git a/dev-python/simpervisor/simpervisor-1.0.0.ebuild b/dev-python/simpervisor/simpervisor-1.0.0-r1.ebuild
index ac7a8e2d6665..344831934f52 100644
--- a/dev-python/simpervisor/simpervisor-1.0.0.ebuild
+++ b/dev-python/simpervisor/simpervisor-1.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,3 +27,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/jupyterhub/simpervisor/pull/50
+ "${FILESDIR}/${P}-yarl.patch"
+)