summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-03 15:04:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-03 15:50:03 +0100
commiteccf4b90065e5bd40dc03ed163e214afd9ec12de (patch)
tree4d4e18f3ced8d36ccb6d525408b548dc414bc274
parentxfce-extra/xfce4-cpufreq-plugin: Bump to 1.2.8 (diff)
downloadgentoo-eccf4b90.tar.gz
gentoo-eccf4b90.tar.bz2
gentoo-eccf4b90.zip
xfce-extra/xfce4-sensors-plugin: Bump to 1.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-sensors-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.4.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/Manifest b/xfce-extra/xfce4-sensors-plugin/Manifest
index 67517f902721..69867471ec89 100644
--- a/xfce-extra/xfce4-sensors-plugin/Manifest
+++ b/xfce-extra/xfce4-sensors-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-sensors-plugin-1.4.3.tar.bz2 508993 BLAKE2B 4e857c2b31b6dc1d9e1f5adeb0b34c1f68c0e3386c7211533c5ffdfddddfc307fd16b0a55b6f8697aab87c62e143f3e8795c1a7ba36c3cfd18e92b56e316c7f0 SHA512 2cb91afaf740db5bbbb8451cfa0540ee979671e6a1a640ad61dfeb41328c057bc16fa668e9d536595ef460bfbd41617e8b3d27f63e02324e9764543fa6a0b2b5
+DIST xfce4-sensors-plugin-1.4.4.tar.bz2 472187 BLAKE2B ab59dea6dd2252c23ee7a74567c16ab040152bbe0012349078d306dcad2c699d6e55b32f7d084c6cdf26f51ff324bcac817ea6f01e3957c74cd7799bddd0a147 SHA512 45a5df383cc950f05f33d3d658b4847890e4136d6c72708a4218f1460a27d44a07a3f726d6c509bc706b963041a5dab3259dd94127636fb196d47ab9a0d6f702
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.4.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.4.ebuild
new file mode 100644
index 000000000000..6de78b078b96
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for acpi, lm-sensors and hddtemp sensors"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-sensors-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-sensors-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+acpi hddtemp libnotify lm-sensors video_cards_nvidia"
+REQUIRED_USE="|| ( hddtemp lm-sensors acpi )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/libxfce4ui-4.16:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16:=
+ hddtemp? (
+ app-admin/hddtemp
+ || (
+ net-analyzer/openbsd-netcat
+ net-analyzer/netcat
+ )
+ )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ lm-sensors? ( >=sys-apps/lm-sensors-3.1.0:= )
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers[tools,static-libs] )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable lm-sensors libsensors)
+ $(use_enable hddtemp)
+ $(use_enable hddtemp netcat)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(use_enable libnotify notification)
+ --disable-pathchecks
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}