summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-04 13:35:52 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-04 13:40:32 +0200
commiteccf574f16c76954aea90e08575b04eb13229e69 (patch)
tree0f1707c00766170deccdba827d869e9a05f0b000
parentsys-boot/cromwell-bin: update HOMEPAGE, #472076 (diff)
downloadgentoo-eccf574f.tar.gz
gentoo-eccf574f.tar.bz2
gentoo-eccf574f.zip
sys-boot/cromwell-bin: Port to EAPI=6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sys-boot/cromwell-bin/cromwell-bin-2.31-r1.ebuild (renamed from sys-boot/cromwell-bin/cromwell-bin-2.31.ebuild)19
-rw-r--r--sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild (renamed from sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild)19
2 files changed, 24 insertions, 14 deletions
diff --git a/sys-boot/cromwell-bin/cromwell-bin-2.31.ebuild b/sys-boot/cromwell-bin/cromwell-bin-2.31-r1.ebuild
index 79016b6601f8..bb8a0479ed89 100644
--- a/sys-boot/cromwell-bin/cromwell-bin-2.31.ebuild
+++ b/sys-boot/cromwell-bin/cromwell-bin-2.31-r1.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=6
+
inherit mount-boot
-IUSE=""
DESCRIPTION="Xbox boot loader precompiled binaries from xbox-linux.org"
-SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
HOMEPAGE="https://sourceforge.net/projects/xbox-linux/"
-RESTRICT="${RESTRICT} strip"
-DEPEND=""
-SLOT="0"
+SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
LICENSE="GPL-2"
+
+SLOT="0"
KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="${RESTRICT} strip"
+
+DEPEND=""
+RDEPEND=""
S=${WORKDIR}/cromwell
src_install () {
dodir /boot/${PN}
insinto /boot/${PN}
- doins ${S}/image.bin ${S}/image_1024.bin ${S}/default.xbe || die
+ doins image{,_1024}.bin default.xbe
}
diff --git a/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild b/sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild
index 9cfa58614e68..7e08e63a21ae 100644
--- a/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild
+++ b/sys-boot/cromwell-bin/cromwell-bin-2.40-r1.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=6
+
inherit mount-boot
-IUSE=""
DESCRIPTION="Xbox boot loader precompiled binaries from xbox-linux.org"
-SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
HOMEPAGE="https://sourceforge.net/projects/xbox-linux/"
-RESTRICT="${RESTRICT} strip"
-DEPEND=""
-SLOT="0"
+SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
LICENSE="GPL-2"
+
+SLOT="0"
KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="${RESTRICT} strip"
+
+DEPEND=""
+RDEPEND=""
S=${WORKDIR}/cromwell-${PV}
src_install () {
dodir /boot/${PN}
insinto /boot/${PN}
- doins ${S}/cromwell.bin ${S}/cromwell_1024.bin ${S}/xromwell.xbe || die
+ doins cromwell{,_1024}.bin xromwell.xbe
}