summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-05-30 18:10:55 -0400
committerMike Pagano <mpagano@gentoo.org>2021-05-30 18:10:55 -0400
commitecdc57a9230502e8202d0898c58ab8a9617a38f9 (patch)
tree2f809c55aa0a947ffc58bc6c7c051726387eb094
parentnsplugins.eclass: Remove last-rited eclass (diff)
downloadgentoo-ecdc57a9.tar.gz
gentoo-ecdc57a9.tar.bz2
gentoo-ecdc57a9.zip
sys-kernel/git-sources: Linux patch 5.13-rc4
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.13_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 46f7506b9cac..8cb28021a1fb 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.12.tar.xz 118112412 BLAKE2B 842d921b9a73d2aaade763dbd2ec67bdfe0275b
DIST patch-5.13-rc1.patch 60248581 BLAKE2B c105c2518de0ad29258262913226d44598f19f50df9f4b5bd0ca3afbf132e9b7d582537c9a91fea1209e3e77ced9ba86c83745ec32bb4c9c940fd843bd2858ea SHA512 0ed817a3b25b9d28889c5754344537cd2266254dbfca87a98a5799594323d5b2cf04d233d0b48289dcf4518ebbabe687e49e7fe00553cbbd0cd2ac0e25fdf46b
DIST patch-5.13-rc2.patch 60699877 BLAKE2B b29e45aa17aefe5adff81bc803890200d810848122240b731fa27d1bc0b08448d8579d6bd2328d11ca67b78346fa2342881e838b9cd657803ce6714a93f8e383 SHA512 2d54f9920d1d639a363989e37aba1e82687e7d6848bb53c4936678f50f178678235e9f45671d9373b1b5e15cbb6837640002038fd8b74d72d0e55d70b54321ba
DIST patch-5.13-rc3.patch 60916953 BLAKE2B 1a1a40b91cbe8ed65151931b1e309068c69ef45817e9bc526297fbbe59e8cb2c69176d71679b4f705a1071af5afc80e4f270f8bf7f089d483123550310b3abb0 SHA512 f0deb6c2482b1416d6e96bc4bdb9f9fe51654b6bd9317f0e68f3cfb252ade3c9c7950fa1f7eea09a61dffc109cb832c04fae6eff0a2178fe932f1bd42a7f17d9
+DIST patch-5.13-rc4.patch 61427853 BLAKE2B 7ce34ed0d43f79a193e549208114e0d5c648c965ed584b84959535867088c083227784b3db6b2072b238f73f10c39ce5e4ea8451dbeb107e0c24bcbb7ccac988 SHA512 39d352e6a32c47006492667aa552b92ca45a5a5919443dc00ee1b7ca2947398a4a2db59185df9e779a1b1a75ba93ea3d88ac07005e3072f24b31d1a6284bc131
diff --git a/sys-kernel/git-sources/git-sources-5.13_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.13_rc4.ebuild
new file mode 100644
index 000000000000..5279e1b05efd
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.13_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.12"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}