summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-31 09:20:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-31 11:20:54 +0200
commitece797cda5d2515e69dcb026cc91c21da8aefd2b (patch)
tree505a3fb2fb1a47d16f8df011b074b3840d9822d4
parentdev-python/cfn-lint: Bump to 0.63.2 (diff)
downloadgentoo-ece797cd.tar.gz
gentoo-ece797cd.tar.bz2
gentoo-ece797cd.zip
dev-python/dirty-equals: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dirty-equals/Manifest1
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.5.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index 1dea98855f88..49f57823e8d6 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1 +1,2 @@
DIST dirty-equals-0.4.gh.tar.gz 41864 BLAKE2B 0b916d37b323e9f587a977b46415432bc11367a6d0c95ac49e47fe604b3ee16c26eaecbbe74464076834c6186f5f0eecc049b211699a3f515ef7fdadc492537a SHA512 f98fa8c9850f26efc44dc2c5cc0ea6d687c07b49980c3eeaa71eaae78930e418c03bb35cb88aab065905443fa354b9b05d44a588458ed37d140d376b943c9da9
+DIST dirty-equals-0.5.0.gh.tar.gz 44684 BLAKE2B ccd0d4e254a529e2b3d1014390d3e21a869e145fc0d9913e01e896ce103d853315d496264fdf611aa1fded8c66673bcb9e38dc41984ebfc566a9621b99240f81 SHA512 5d89105e3eb4e3dd52423aafed6c3ddf50890cfb3c03623723d0ab79f9814e892ba91cf789fa495ecc663b03c49516687fc2c1bc548816d60ade4f64df561ab9
diff --git a/dev-python/dirty-equals/dirty-equals-0.5.0.ebuild b/dev-python/dirty-equals/dirty-equals-0.5.0.ebuild
new file mode 100644
index 000000000000..ce09838079c0
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}