summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-16 19:09:27 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-16 19:17:20 +0200
commitece7dbc231858bab154aabd9ba16e6f61be7719f (patch)
tree8ff0b3ac3061195e03d38ba3d417b922539b2c72
parentdev-perl/Crypt-URandom: EAPI=8 bump (diff)
downloadgentoo-ece7dbc2.tar.gz
gentoo-ece7dbc2.tar.bz2
gentoo-ece7dbc2.zip
dev-perl/CryptX: Version bump 0.073
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--dev-perl/CryptX/CryptX-0.73.0.ebuild56
-rw-r--r--dev-perl/CryptX/Manifest1
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-perl/CryptX/CryptX-0.73.0.ebuild b/dev-perl/CryptX/CryptX-0.73.0.ebuild
new file mode 100644
index 000000000000..3e54df75c253
--- /dev/null
+++ b/dev-perl/CryptX/CryptX-0.73.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MIK
+DIST_VERSION=0.073
+inherit perl-module
+
+DESCRIPTION="Self-contained crypto toolkit"
+LICENSE="|| ( Artistic GPL-1+ ) public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86"
+IUSE="minimal"
+
+RDEPEND="
+ !minimal? (
+ dev-perl/JSON
+ )
+"
+# dev-libs/libtommath
+# dev-libs/libtomcrypt
+
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ !minimal? (
+ >=virtual/perl-Math-BigInt-1.999.715
+ >=virtual/perl-Storable-2.0.0
+ )
+ )
+"
+
+#DEPEND="
+# dev-libs/libtommath
+# dev-libs/libtomcrypt
+#"
+
+PERL_RM_FILES=(
+ t/002_all_pm.t
+ t/003_all_pm_pod.t
+ t/004_all_pm_pod_spelling.t
+ t/005_all_pm_pod_coverage.t
+)
+
+#src_configure() {
+# CRYPTX_LDFLAGS='-ltommath -ltomcrypt' perl-module_src_configure
+#}
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/CryptX/Manifest b/dev-perl/CryptX/Manifest
index 717792cc14fe..44812ac8656b 100644
--- a/dev-perl/CryptX/Manifest
+++ b/dev-perl/CryptX/Manifest
@@ -1 +1,2 @@
DIST CryptX-0.072.tar.gz 1643459 BLAKE2B 28bb06ef870287ccd9f46c2ed5d7b434e33563046598cff5c505c74c68d29b5bf58ad0dd3a5d968c6717ccb6cfdbf1b33982b49a87b9e4f7c85af9ab40d617d5 SHA512 9e51181b14c08f8c0769089f8c9a5feefa7c4f1a8dff2501cf1d1d475ae162f8df35c7cceff9d1742552951e13450cac9d70eb1ead8178e0c95cd1abfea5e03c
+DIST CryptX-0.073.tar.gz 1643681 BLAKE2B 01a8a9082d4abbe6ae17b1fb53f9e0fbcf2aa8124381f11124ee55a23046f2c08aa403ce3a38a14f6bd36b3f61b539d704c913b0bea18d5c90a1b8336c464229 SHA512 592e4d657870785d7d13ba74bdc28c62575c4cf1ed95fb8de4524617ae92d196c5f1bc031ea4a39601ddb6ea8484dc28a4f2ddf53e2348466e9f8307956d0646