summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2020-08-02 18:07:27 -0400
committerSam James <sam@gentoo.org>2020-08-07 17:57:47 +0000
commitecf767fe583c3b8e3e3e697cdced7c0e6e4755c4 (patch)
tree0c9fef8cf7bc41d55a204c0dad2db61a2a0a3f6d
parentwww-client/elinks: fix lua support (diff)
downloadgentoo-ecf767fe583c3b8e3e3e697cdced7c0e6e4755c4.tar.gz
gentoo-ecf767fe583c3b8e3e3e697cdced7c0e6e4755c4.tar.bz2
gentoo-ecf767fe583c3b8e3e3e697cdced7c0e6e4755c4.zip
www-client/elinks: add support for gnutls
Signed-off-by: Felix Janda <felix.janda@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-client/elinks/elinks-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 0fd8b8d67f7f..16eb304d3e7a 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://elinks.or.cz/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm guile idn ipv6
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn ipv6
javascript libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib"
BDEPEND="virtual/pkgconfig"
@@ -31,8 +31,11 @@ RDEPEND="
ruby? ( dev-lang/ruby:* dev-ruby/rubygems:* )
samba? ( net-fs/samba )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ gnutls? ( net-libs/gnutls:= )
)
tre? ( dev-libs/tre )
X? ( x11-libs/libX11 x11-libs/libXt )
@@ -96,11 +99,12 @@ src_configure() {
myconf+=( --enable-fastmem )
fi
- # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
- # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
- # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
if use ssl ; then
- myconf+=( --with-openssl="${EPREFIX}"/usr )
+ if use gnutls ; then
+ myconf+=( --with-gnutls )
+ else
+ myconf+=( --with-openssl="${EPREFIX}"/usr )
+ fi
else
myconf+=( --without-openssl --without-gnutls )
fi