summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-01-28 10:13:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-01-28 10:16:37 +0200
commitecfc690db1af162bba292df7e7bde0e5eea5a140 (patch)
tree42eee7f84a23cfaeb26cee3864d4450e3db31c34
parentapp-emulation/qemu: drop old (diff)
downloadgentoo-ecfc690d.tar.gz
gentoo-ecfc690d.tar.bz2
gentoo-ecfc690d.zip
dev-vcs/git-lfs: Bump to 2.13.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.13.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 613df178825c..a7587c4696dd 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,2 +1,3 @@
DIST git-lfs-2.11.0.tar.gz 2839623 BLAKE2B e9d0e8ea37f19617a4f727abdc93c3c937052ad98b6ac40de27ced6b250789701797d04f1bf795b259e83155e5d8a1ca122dbf8b40503c2c41d6d891a3ecf096 SHA512 2117b425864a36f773c14d34c78999636d836646184cf8d89045ef6de90cbded873d4de4613ecfafb0fa2ea8ae068e11f5ae22eed6af01715b5fac9be70f033b
DIST git-lfs-2.12.1.tar.gz 2848245 BLAKE2B 745a1ad252b925074a9ddfd9f899098dfca0b672b176178675652d910737f76c2c55aa502d0a544ad36a7eee00a464e12b9bb178ccd1fb118c2a96b362de80d1 SHA512 728bf414910a9a9106ea6769b939aae9ec25976e686399d0612e8ff99131a6571641b4121cb123ad6c32fc6dd59674ca50416a48e4771924b27062326df78ce0
+DIST git-lfs-2.13.1.tar.gz 2526962 BLAKE2B 3f3af1c0f976a17c108159fff15a065600f32af2a31d459fcd4b9e64d8e77aa8569aa81c932f38713ff6bafdb636aae464a2044f2664d124ca7de0a7157da969 SHA512 48397ed0ae976544c80df59df1991b0f35606d0a3ed9eb0aef66857e5bf2974e8ad5677be98b53433628d26f9e5135e9f28b15c8789cc6a4ed091946b79e6fce
diff --git a/dev-vcs/git-lfs/git-lfs-2.13.1.ebuild b/dev-vcs/git-lfs/git-lfs-2.13.1.ebuild
new file mode 100644
index 000000000000..641f9c79a60b
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.13.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/git-lfs/git-lfs
+inherit go-module
+
+DESCRIPTION="Command line extension and specification for managing large files with git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+if [[ "${PV}" = 9999* ]]; then
+ EGIT_REPO_URI="https://${EGO_PN}"
+ inherit git-r3
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
+SLOT="0"
+IUSE="doc test"
+
+BDEPEND="doc? ( app-text/ronn )"
+RDEPEND="dev-vcs/git"
+
+RESTRICT+=" !test? ( test )"
+
+DOCS=(
+ CHANGELOG.md
+ CODE-OF-CONDUCT.md
+ CONTRIBUTING.md
+ README.md
+ SECURITY.md
+)
+
+src_compile() {
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
+ -mod vendor -v -work -x
+ )
+ go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ einstalldocs
+ use doc && doman docs/man/*.1
+}
+
+src_test() {
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
+ -mod vendor
+ )
+ go test "${mygotestargs[@]}" ./... || die
+}
+
+pkg_postinst () {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog ""
+ elog "Run \'git lfs install\' once for each user account manually."
+ elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
+ fi
+}