summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-20 06:33:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-20 07:24:02 +0100
commited01baab8ff01a43f0121e3e35ce5f61f5c60af9 (patch)
tree0983667328b87e83df907dacc384a466942cea05
parentdev-python/sphinxcontrib-spelling: Bump to 8.0.0 (diff)
downloadgentoo-ed01baab8ff01a43f0121e3e35ce5f61f5c60af9.tar.gz
gentoo-ed01baab8ff01a43f0121e3e35ce5f61f5c60af9.tar.bz2
gentoo-ed01baab8ff01a43f0121e3e35ce5f61f5c60af9.zip
dev-python/PyGithub: Bump to 1.58.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.58.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index 6262ace17b25..7178a4f43652 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1 +1,2 @@
DIST PyGithub-1.57.gh.tar.gz 3159952 BLAKE2B e753a72c0fe20f0697ff3246fd2c3445571079ae18bee50abf6543da51d9e889c67cafa0bf36a980223f3423cf880c36d24ce74a6bf245117a080186a209ddcb SHA512 6c8880d21c5134581be6bc5549184c3f13cef8f360a46a459234f22f3dd4fc5f8b573cc3a5d870bba6c6129ff7b670e739d87e42f2e34ddcdf357a3fe2b3cadc
+DIST PyGithub-1.58.0.gh.tar.gz 3172006 BLAKE2B a1d71c11a359d296fbf895a1fc3c9f60490b7c63fd65c92a3a025c2b306ca281a03cf65d49a1dcca5bb0a9c537b130f5ef7bd9ab594f1521a106857f83669f65 SHA512 cbaca0d116be56f6d44084892e52b7073378743178342a480c2b3990542e476bee52947d56f8be950d05d5c06fb8eaeb32acb35285c79e0cbbd8b24239af6cba
diff --git a/dev-python/PyGithub/PyGithub-1.58.0.ebuild b/dev-python/PyGithub/PyGithub-1.58.0.ebuild
new file mode 100644
index 000000000000..5ad78d5f92e7
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.58.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="
+ https://github.com/PyGithub/PyGithub/
+ https://pypi.org/project/PyGithub/
+"
+SRC_URI="
+ https://github.com/PyGithub/PyGithub/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest