summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-05-12 19:17:15 +0300
committerMart Raudsepp <leio@gentoo.org>2024-05-12 19:40:03 +0300
commited0ea3cf54700bbdb0c3dfdecef7d79c9a047c9a (patch)
tree2f532b99d58c3277039508efa2f233822a2b3958
parentdev-python/webcolors: Fix variable order (diff)
downloadgentoo-ed0ea3cf54700bbdb0c3dfdecef7d79c9a047c9a.tar.gz
gentoo-ed0ea3cf54700bbdb0c3dfdecef7d79c9a047c9a.tar.bz2
gentoo-ed0ea3cf54700bbdb0c3dfdecef7d79c9a047c9a.zip
sys-kernel/asahi-sources: add 6.8.9_p5
* Fixes v6.8.9 Bluetooth LE regression on Apple Silicon bcm438x * Adjusts dcp FB flip complete timestamps to fix half-rate display with some compositors on dcpext (M2 desktops and M1/2 Pro/Max Macbook Pros) Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--sys-kernel/asahi-sources/Manifest1
-rw-r--r--sys-kernel/asahi-sources/asahi-sources-6.8.9_p5.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-kernel/asahi-sources/Manifest b/sys-kernel/asahi-sources/Manifest
index 9973d6d0523c..0c86b984215f 100644
--- a/sys-kernel/asahi-sources/Manifest
+++ b/sys-kernel/asahi-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-asahi-6.8.8-2.tar.gz 235265018 BLAKE2B cf543955971865d65c048b7021a8bf4d9711294afd49e4ce31bf3e4761dea8724950a52a7b6b852645760e0abb1ca2abe1ac6c3feafbcb933a53e56dcc4044e4 SHA512 101566de3777517d151effcdd2e38b6a5d5961754734cdabfae7c359bbf0f35e2c7a4ecb912d4c300adb3f09ecaa31eafaf076d849171e0e5244ec29a0bf30a4
DIST linux-asahi-6.8.9-3.tar.gz 235275610 BLAKE2B 8ee3ff2572a02851d66239c65187312a0f67aa492d9c3b3a734e291b250acbf9450960c745687ff98a339e4cc14a2eab7675c08d39f88de0c0aa7c320d20bdc8 SHA512 ebd854b357a1d0a7663129f48956da559bc23a4347836dd0c3a3eb8cd47013ed86d83711dc2b7a221c28f51bd0c42c0b1ea2302ef45ee4a2ddfbfacf33e6efc2
+DIST linux-asahi-6.8.9-5.tar.gz 235264452 BLAKE2B 5a08d3df1d0e1fc274a68f29ab592c790421d58dafa5533b7f526f13c5046d668e0c864b9a71f2c5b736a1890a65ba0877694b11bbde9acf5ff873f7a8a5a167 SHA512 e592959bfd546588df26bcec6b6de86dc3450d6ae89b073b272dd41b9927a7c2b09b9f8ff77b3cc80393b65821062eddabe351f177bfc1f732f11d685594412f
diff --git a/sys-kernel/asahi-sources/asahi-sources-6.8.9_p5.ebuild b/sys-kernel/asahi-sources/asahi-sources-6.8.9_p5.ebuild
new file mode 100644
index 000000000000..f975144c1b51
--- /dev/null
+++ b/sys-kernel/asahi-sources/asahi-sources-6.8.9_p5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+#K_WANT_GENPATCHES="base extras experimental"
+#K_GENPATCHES_VER="5"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+if [[ ${PV} != ${PV/_rc} ]] ; then
+ # $PV is expected to be of following form: 6.0_rc5_p1
+ MY_TAG="$(ver_cut 6)"
+ MY_P="asahi-$(ver_rs 2 - $(ver_cut 1-4))-${MY_TAG}"
+else
+ # $PV is expected to be of following form: 5.19.0_p1
+ MY_TAG="$(ver_cut 5)"
+ if [[ "$(ver_cut 3)" == "0" ]] ; then
+ MY_P="asahi-$(ver_cut 1-2)-${MY_TAG}"
+ else
+ MY_P="asahi-$(ver_cut 1-3)-${MY_TAG}"
+ fi
+fi
+
+DESCRIPTION="Asahi Linux kernel sources"
+HOMEPAGE="https://asahilinux.org"
+KERNEL_URI="https://github.com/AsahiLinux/linux/archive/refs/tags/${MY_P}.tar.gz -> linux-${MY_P}.tar.gz"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}
+"
+
+KEYWORDS="~arm64"
+IUSE="rust"
+
+DEPEND="
+ ${DEPEND}
+ rust? (
+ || (
+ >=dev-lang/rust-bin-1.76[rust-src,rustfmt]
+ >=dev-lang/rust-1.76[rust-src,rustfmt]
+ )
+ dev-util/bindgen
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/asahi-sources-6.6.0_p16-enable-speakers-stage1.patch"
+ "${FILESDIR}/asahi-sources-6.6.0_p16-enable-speakers-stage2.patch"
+)
+
+src_unpack() {
+ unpack linux-${MY_P}.tar.gz
+ mv linux-${MY_P} linux-${KV_FULL} || die "Could not move source tree"
+}
+
+src_prepare() {
+ default
+ cd "${WORKDIR}/linux-${KV-FULL}" || die
+ # XXX: Genpatches do not yet work with Rust kernels
+ #handle_genpatches --set-unipatch-list
+ #[[ -n ${UNIPATCH_LIST} || -n ${UNIPATCH_LIST_GENPATCHES} || -n ${UNIPATCH_LIST_DEFAULT} ]] && \
+ # unipatch "${UNIPATCH_LIST_DEFAULT} ${UNIPATCH_LIST_GENPATCHES} ${UNIPATCH_LIST}"
+ #unpack_fix_install_path
+ #env_setup_xmakeopts
+ echo "-${MY_TAG}" > localversion.10-pkgrel || die
+ cd "${S}" || die
+}
+
+pkg_postinst() {
+ einfo "For more information about Asahi Linux please visit ${HOMEPAGE},"
+ einfo "or consult the Wiki at https://github.com/AsahiLinux/docs/wiki."
+ kernel-2_pkg_postinst
+}