summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-02-21 19:35:52 +0300
committerSam James <sam@gentoo.org>2023-02-22 07:42:18 +0000
commited21a3aa28e193ce16d039bc3f6db3a5381640a5 (patch)
tree5eb554684fac97783c3ed4489e4251c54e5e4d52
parentdev-python/pebble: increase attempts for broken test on slow CPU (diff)
downloadgentoo-ed21a3aa28e193ce16d039bc3f6db3a5381640a5.tar.gz
gentoo-ed21a3aa28e193ce16d039bc3f6db3a5381640a5.tar.bz2
gentoo-ed21a3aa28e193ce16d039bc3f6db3a5381640a5.zip
dev-games/aseprite: additional fixes for gcc13
Closes: https://bugs.gentoo.org/895616 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29706 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-games/aseprite/aseprite-1.2.40.ebuild1
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.40_laf-gcc13.patch47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-games/aseprite/aseprite-1.2.40.ebuild b/dev-games/aseprite/aseprite-1.2.40.ebuild
index f13050e1e1d3..bd7646097d95 100644
--- a/dev-games/aseprite/aseprite-1.2.40.ebuild
+++ b/dev-games/aseprite/aseprite-1.2.40.ebuild
@@ -74,6 +74,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.2.35_laf_fixes.patch"
"${FILESDIR}/${PN}-1.2.40_musl_pthreads.patch"
"${FILESDIR}/${PN}-1.2.40_ixwebsocket-gcc13.patch"
+ "${FILESDIR}/${PN}-1.2.40_laf-gcc13.patch"
)
src_prepare() {
diff --git a/dev-games/aseprite/files/aseprite-1.2.40_laf-gcc13.patch b/dev-games/aseprite/files/aseprite-1.2.40_laf-gcc13.patch
new file mode 100644
index 000000000000..3d7ff309342b
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.2.40_laf-gcc13.patch
@@ -0,0 +1,47 @@
+From 59c6af303dea4c6dc0c9da687ec73612929eacfc Mon Sep 17 00:00:00 2001
+From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
+Date: Tue, 21 Feb 2023 17:01:04 +0300
+Subject: [PATCH] Fix compilation on GCC13
+
+GCC-13 changes internal cstdint includes, and now files that uses
+standard integer types should directly include cstdint header.
+
+See: https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+See: https://github.com/aseprite/laf/pull/55
+Bug: https://bugs.gentoo.org/865117
+Bug: https://bugs.gentoo.org/895616
+--- a/laf/base/file_content.h
++++ b/laf/base/file_content.h
+@@ -9,6 +9,7 @@
+ #pragma once
+
+ #include "base/buffer.h"
++#include "base/ints.h"
+
+ #include <cstdio>
+ #include <string>
+--- a/laf/base/sha1.h
++++ b/laf/base/sha1.h
+@@ -11,6 +11,8 @@
+ #include <vector>
+ #include <string>
+
++#include "base/ints.h"
++
+ extern "C" struct SHA1Context;
+
+ namespace base {
+--- a/laf/base/sha1_rfc3174.h
++++ b/laf/base/sha1_rfc3174.h
+@@ -18,6 +18,8 @@
+ #define BASE_SHA1_RFC3174_H_INCLUDED
+ #pragma once
+
++#include "base/ints.h"
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+--
+2.39.2
+