summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-26 19:50:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-26 19:50:58 +0100
commited2ab0872423ed6774cd5b5990c855ccf7aaf04e (patch)
tree8ab356aba1d3af13771826b49f54cdeb97a5fa8f
parentsys-kernel/gentoo-kernel: Bump to 5.10.3 (diff)
downloadgentoo-ed2ab0872423ed6774cd5b5990c855ccf7aaf04e.tar.gz
gentoo-ed2ab0872423ed6774cd5b5990c855ccf7aaf04e.tar.bz2
gentoo-ed2ab0872423ed6774cd5b5990c855ccf7aaf04e.zip
net-misc/youtube-dl: Bump to 2020.12.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2020.12.26.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 3653f97b8699..499be492fa4e 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2020.12.14.tar.gz 3229047 BLAKE2B 5a54ce2f7f754640c29c9183495c5933340f6d2b94e4bc958eb6590ada08b12b8333d7c61106e1c00d1ef039a7d203382930833d2734f80bf361cf6858ef09f8 SHA512 8a7d96656ef6803afdff90a2c528cdac5354a10996a631c54c722615ccbf879fd5e89b85f9e369cb9d1fd239fc095db4e232a5c420cdd902f5ffbe76f4e3d1a5
DIST youtube-dl-2020.12.22.tar.gz 3238866 BLAKE2B 8f2f07c59b4d64ed9176bdbfcb858c4f90d7acfe97fad02bf98c517e46fca049421deb764a039466557cfda20d3921535e0e0ae0be4c9afe514a2242a18a45b5 SHA512 2acd7256d3479387db25cc85882da77996cb8fe09a6c6400a9580c1c10317ab72ee18b0e1c2429f533992c41e172f2bbd8c9570daed01578aa971b1ba9d3fbc2
+DIST youtube-dl-2020.12.26.tar.gz 3246941 BLAKE2B 7e2c3cea21e10458c1ee3718e9e039301590d8213367229818f36df488865eca7d1e76a27dfc1d4374d15314f271b12fc2c548f43927c724a936399fffa5ac19 SHA512 6a577aa435639af7c5e60183d7548d5f0a74cdea3cb87edaa81dc20ce5ca788ba99f731cbaacffdae74cc10d530e6b8d5b0cfccaf4cb9c2f4cc4f9c540b2d175
diff --git a/net-misc/youtube-dl/youtube-dl-2020.12.26.ebuild b/net-misc/youtube-dl/youtube-dl-2020.12.26.ebuild
new file mode 100644
index 000000000000..04afa74ada09
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2020.12.26.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}