summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-15 04:01:18 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-15 04:01:27 +0200
commited4390b3287bfecf0e9873ab1ddece17fdae57ec (patch)
treeee943f8ba67a226c374a244cf050aa9f8f77dd9a
parentnet-news/rssguard: Bump to 4.7.0 (diff)
downloadgentoo-ed4390b3287bfecf0e9873ab1ddece17fdae57ec.tar.gz
gentoo-ed4390b3287bfecf0e9873ab1ddece17fdae57ec.tar.bz2
gentoo-ed4390b3287bfecf0e9873ab1ddece17fdae57ec.zip
dev-python/pyproject-fmt: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index fc26781b36cc..5abda57b1698 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -2,3 +2,4 @@ DIST pyproject_fmt-1.8.0.tar.gz 16696 BLAKE2B 1614fd6da4bb7be818825138b69b826b71
DIST pyproject_fmt-2.0.2.tar.gz 8647 BLAKE2B aae92d952883adce7ee6bd92a29517064dfd25ed6a90ca4543ec4093ce57bb17d2315134d5709d084e17098680a861014fc35d18feeac17ba9c9cca4d501959a SHA512 750f8006a30425ccfcd28909f06208344776a250698025f7f1c8a33d7316e4dfe9f06baea6050848691940846ea1ef3dfdd1a7878c72bb611f1a6b9b2bed3ff7
DIST pyproject_fmt-2.0.3.tar.gz 8646 BLAKE2B 83b5984f513341e10fabf81eeb2466c54502da78e0d722795f814241dbee66f507a9167df7ef7b4654ab1178755eb6d976dab9954e8ae0924794841a39cc952a SHA512 e74c2d28cfafacbccc8b55600004353d2633c8946a6abc894e73e40f173794b2845eea50f44808009079161b3ab1067c95696080bdcfff9d387bfe04d9fd119d
DIST pyproject_fmt-2.0.4.tar.gz 8648 BLAKE2B 8886994d483c7829b947b4b53dd6808702f61e1177e4f24794cff56218199de990358cd27451a16a2583a73004438aedefc1999bdf9295e03c4b40388a94f0e6 SHA512 d20cde82082e4bcd3504eeb43bc1c3979cc55ad0522c8e1b907bfcf0af0c8203a53ef85987416a79c1259ab841d8bb71a5552b07ac2585dd47a8b278a0100110
+DIST pyproject_fmt-2.1.0.tar.gz 9012 BLAKE2B 5ddc95d9f5ef322f1895772d63a3d6a800172d57655f795d74a077628020ab54ee1a4ef52b3a317504567ce2a13b4c6cd229f7ee05dbcc5fecabb0762679f12e SHA512 00a9541c61ca1924a78a48736962df39e055cf61cd2a312dc0fd2c7efb247d504f7e747912d328e689de25049c944cc2b422dc6c74c1c1e910b6294bd2306944
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild
new file mode 100644
index 000000000000..b2e68d5c3f16
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ ~dev-python/pyproject-fmt-rust-1.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest