summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-04 06:01:03 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-04 06:02:06 +0000
commited61d295f7fc1cce7551a29847d54645748edaef (patch)
tree235bcb4aeac1c74fd26781725417110f89e135b1
parentdev-libs/libgpuarray: initial import (diff)
downloadgentoo-ed61d295.tar.gz
gentoo-ed61d295.tar.bz2
gentoo-ed61d295.zip
dev-python/theano: version bump
experimental gpu support Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/theano/Manifest1
-rw-r--r--dev-python/theano/theano-0.8.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/theano/Manifest b/dev-python/theano/Manifest
index eb5e9e17510f..33585815dfcc 100644
--- a/dev-python/theano/Manifest
+++ b/dev-python/theano/Manifest
@@ -1,2 +1,3 @@
DIST Theano-0.6.0.tar.gz 1763756 SHA256 aaa75f9a9b7bf50f09ddcc01fb993cf47513179d0a7bee3d96bfeebd66e76083 SHA512 6333c673df809bed3af952e0759cce4878ed21684367c6eb20e422363c7c5696ea59239ff6a448c6a32771b1069d441b0e3d049f9708ae69d790412303b8ebbd WHIRLPOOL 946fcacb87b7745e72282f5f7e6b67db5fd0e365f55b2c97a8e9e506e30986d90da7c3789636892ca316da33f4f064f99d31fc3771678457dd609fd0c43d9010
DIST Theano-0.7.0.tar.gz 1985387 SHA256 05b0f6d2467735abea13bdc5c2c1ce3c53f1b89f9ebc5a43abdf71f88cf818b3 SHA512 6e6bf9afdebf3c281d71f5ceda73792e0a52b403b18776a639665767ac73ac4920b5042e29d656d517b8f023e5f9cd5a27086e0456dc40c42abf6f3569da3f06 WHIRLPOOL b79906e39eb8f7cad26160148465b4719d1011e1a4626c98fdb55cd273ff289b0c01278d51fdc8271b71434be0fd036f8259a315b07639e9ad83d1e3bf313687
+DIST Theano-0.8.2.tar.gz 2914631 SHA256 7463c8f7ed1a787bf881f36d38a38607150186697e7ce7e78bfb94b7c6af8930 SHA512 d7bad7ed4c9453470b66df2ada4587fbe9effc134c0604d11576630a613568386d41aa7dd4a77f8b7a1eb6d8a2f76a8e809b1ac3ae18c85a0c55ba4a059b865e WHIRLPOOL 05ae7308054e74fcbcb9057aca5a0e8ed7db7980e4a258bf5143f2a1ae9cfb430808a48467d6a185cdb4215ce33163a1e6e1961284e593c90cc9be6f0c9a5cbb
diff --git a/dev-python/theano/theano-0.8.2.ebuild b/dev-python/theano/theano-0.8.2.ebuild
new file mode 100644
index 000000000000..c48464fcf75c
--- /dev/null
+++ b/dev-python/theano/theano-0.8.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 versionator
+
+MYPN=Theano
+MYP=${MYPN}-$(replace_version_separator 3 '')
+
+DESCRIPTION="Define and optimize multi-dimensional arrays mathematical expressions"
+HOMEPAGE="https://github.com/Theano/Theano"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc test"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-parameterized[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )"
+S="${WORKDIR}/${MYP}"
+
+python_prepare_all() {
+ # remove bundled six
+ find -type f -name "*.py" -exec \
+ sed -e 's:theano.compat.six:six:g' -i '{}' + || die
+ rm ${PN}/compat/six.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}
+
+pkg_postinst() {
+ optfeature \
+ "Make picture of Theano computation graph" dev-python/pydot-ng \
+ "Required for GPU/CPU code generation" dev-python/pygpu
+}