summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-03 18:13:14 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-03 18:29:58 +0100
commited6a2132e43a7d9c00b1bbe6b9a14edc6a0c06f0 (patch)
tree1565529733e166df95cc2fee91160977e49fc05b
parentarch/arm/package.use.stable.mask: use.stable.mask webkit USE flag for gimp (diff)
downloadgentoo-ed6a2132.tar.gz
gentoo-ed6a2132.tar.bz2
gentoo-ed6a2132.zip
app-arch/lz4: update -9999, switch to CMake
Update the URLs in the live ebuild and switch it to use the CMake build system. It is free of all fancy things we had to hack around in Makefiles, and links all executables to the shared library. It lacks tests but they were not very useful anyway.
-rw-r--r--app-arch/lz4/lz4-9999.ebuild58
1 files changed, 15 insertions, 43 deletions
diff --git a/app-arch/lz4/lz4-9999.ebuild b/app-arch/lz4/lz4-9999.ebuild
index 4ed5767cfcc9..3e59139af39c 100644
--- a/app-arch/lz4/lz4-9999.ebuild
+++ b/app-arch/lz4/lz4-9999.ebuild
@@ -2,63 +2,35 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit multilib multilib-minimal toolchain-funcs
+inherit cmake-multilib
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/Cyan4973/lz4.git"
+ EGIT_REPO_URI="https://github.com/lz4/lz4.git"
EGIT_BRANCH=dev
else
- MY_PV="r${PV##0_p}"
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://github.com/Cyan4973/lz4/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="Extremely Fast Compression algorithm"
-HOMEPAGE="https://github.com/Cyan4973/lz4"
+HOMEPAGE="https://github.com/lz4/lz4"
LICENSE="BSD-2 GPL-2"
-# Upstream has trouble keeping ABI stable, so please test new versions
-# with abi-compliance-checker and update the subslot every time ABI
-# changes. This is the least we can do to keep things sane.
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+# note: abi-tracker is most likely wrong about 1.7.3 changing ABI,
+# the maintainer is looking into fixing that
SLOT="0/r131"
-IUSE="static-libs test valgrind"
+IUSE="static-libs"
-DEPEND="test? ( valgrind? ( dev-util/valgrind ) )"
+CMAKE_USE_DIR=${S}/contrib/cmake_unofficial
-src_prepare() {
- if ! use valgrind; then
- sed -i -e '/^test:/s|test-mem||g' programs/Makefile || die
- fi
- multilib_copy_sources
-}
-
-lmake() {
- emake \
- BUILD_STATIC=$(usex static-libs) \
- PREFIX="${EPREFIX}/usr" \
- LIBDIR="${EPREFIX}"/usr/$(get_libdir) \
- "$@"
-}
-
-multilib_src_compile() {
- tc-export CC AR
- # we must not use the 'all' target since it builds test programs
- # & extra -m32 executables
- lmake -C lib liblz4 liblz4.pc
- lmake -C programs lz4 lz4c
- # work around lack of proper target dependencies
- touch lib/liblz4
-}
-
-multilib_src_test() {
- lmake -j1 test
-}
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
-multilib_src_install() {
- lmake install DESTDIR="${D}"
+ cmake-utils_src_configure
}