summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 05:27:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 05:50:30 +0100
commited770304950f9074a156bc0dcb18957f07e5361a (patch)
tree9e5f9fe3595b4419a58f9e4ed0ab8d5d39d6f459
parentapp-admin/awscli: Bump to 1.27.84 (diff)
downloadgentoo-ed770304.tar.gz
gentoo-ed770304.tar.bz2
gentoo-ed770304.zip
dev-python/line_profiler: Bump to 4.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-4.0.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 882f2c75b700..17c0ab984d2c 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1 +1,2 @@
DIST line_profiler-4.0.2.gh.tar.gz 63855 BLAKE2B e2f077214fb1387504446882396b3b48f5dc309b9de9ff7d7f39dfb96361e0b4ce5461510c878caabbfa4c2723fe65f2eeca5eb4fb261f1a735ebe32beb3b0fe SHA512 ef07d51a33cc71de0409f8dbdae47c738a8088ece577b077e9b7ff6e4f296da30f7843ef01f3bdcedadc1ad778fe625c0880e6a27844f49cda780f2fd6960acf
+DIST line_profiler-4.0.3.gh.tar.gz 63873 BLAKE2B b34baa89d6625e0887823a44b89fc1b5c3a069ba5d160b959fd435080cfa64e68f693a03e3ed2741efc6d7ca71a60ac0b0e43bd8ba3101089a4e3d0d6c88303e SHA512 3f7734e3651588b1d40df0836d8c93384541b6a010e70becc419101377ac90374fc8f202b927b42ca4aec3e030d9ed52f4955f9fcae3c8d0396f96e21a29eeac
diff --git a/dev-python/line_profiler/line_profiler-4.0.3.ebuild b/dev-python/line_profiler/line_profiler-4.0.3.ebuild
new file mode 100644
index 000000000000..cc5995f63faa
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-4.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export LINE_PROFILER_BUILD_METHOD=cython
+
+python_test() {
+ cd tests || die
+ epytest
+}