summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-15 16:44:46 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-15 17:00:02 -0400
commited9026c4952af368562337687d3eecde930476b2 (patch)
treebd9a19f379bdbf8e2c343dbe4ceaefc9c60df470
parentgames-arcade/gnome-nibbles: Remove vala version restrictions (diff)
downloadgentoo-ed9026c4.tar.gz
gentoo-ed9026c4.tar.bz2
gentoo-ed9026c4.zip
mail-client/geary: Fix test failure with libxml2 >= 2.9.14
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--mail-client/geary/files/40.0-Correct-the-conditional-comments-in-the-test-data.patch38
-rw-r--r--mail-client/geary/geary-40.0-r1.ebuild4
2 files changed, 42 insertions, 0 deletions
diff --git a/mail-client/geary/files/40.0-Correct-the-conditional-comments-in-the-test-data.patch b/mail-client/geary/files/40.0-Correct-the-conditional-comments-in-the-test-data.patch
new file mode 100644
index 000000000000..5c01bf9a32f7
--- /dev/null
+++ b/mail-client/geary/files/40.0-Correct-the-conditional-comments-in-the-test-data.patch
@@ -0,0 +1,38 @@
+From 8fb10db1de1fac2ca99fab246a276620ffd6f02b Mon Sep 17 00:00:00 2001
+From: Richard Adenling <dreeze@gmail.com>
+Date: Tue, 10 May 2022 21:18:01 +0200
+Subject: [PATCH] Correct the conditional comments in the test data
+
+This fixes the problem with libxml2 2.9.14 not considering <![ to be a
+valid way to open a tag anymore.
+
+Closes #1367
+---
+ test/engine/rfc822/rfc822-message-data-test.vala | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/engine/rfc822/rfc822-message-data-test.vala b/test/engine/rfc822/rfc822-message-data-test.vala
+index 613e4b9a..d5e25ea0 100644
+--- a/test/engine/rfc822/rfc822-message-data-test.vala
++++ b/test/engine/rfc822/rfc822-message-data-test.vala
+@@ -763,7 +763,7 @@ ttp://p.ebaystatic.com/aw/email/Welcome_Day_0/spacer.gif" width=3D"5" heigh=
+ t=3D"1" alt=3D"" border=3D"0" style=3D"display:block; width: 5px !important=
+ "></td>
+ </tr>
+-<![if ! gte mso 9]>
++<!--[if ! gte mso 9]>
+ <tr>
+ <td style=3D"border-collapse: collapse !important;
+ border-spacing: 0; !important; padding: 0"><img src=3D"http://p.ebaystatic.=
+@@ -803,7 +803,7 @@ ttp://p.ebaystatic.com/aw/email/Welcome_Day_0/spacer.gif" width=3D"5" heigh=
+ t=3D"1" alt=3D"" border=3D"0" style=3D"display:block; width: 5px !important=
+ "></td>
+ </tr>
+-<![if ! gte mso 9]>
++<!--[if ! gte mso 9]>
+ <tr>
+ <td style=3D"border-collapse: collapse !important;
+ border-spacing: 0; !important; padding: 0"><img src=3D"http://p.ebaystatic.=
+--
+2.35.1
+
diff --git a/mail-client/geary/geary-40.0-r1.ebuild b/mail-client/geary/geary-40.0-r1.ebuild
index 9b3196a2df32..46711534adaf 100644
--- a/mail-client/geary/geary-40.0-r1.ebuild
+++ b/mail-client/geary/geary-40.0-r1.ebuild
@@ -69,6 +69,10 @@ BDEPEND="
net-libs/libsoup:2.4[introspection,vala]
"
+PATCHES=(
+ "${FILESDIR}"/${PV}-Correct-the-conditional-comments-in-the-test-data.patch
+)
+
src_prepare() {
vala_src_prepare
gnome2_environment_reset