summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongsu Park <dpark@linux.microsoft.com>2022-02-18 12:27:49 +0100
committerSam James <sam@gentoo.org>2022-02-18 17:56:35 +0000
commited9829038751fab208ed07a97a35fa3168edae93 (patch)
treec298c0726c0353bc1a1abff9eab4c45057ea2773
parentapp-editors/vim: fix conflicts in 8.2.{4285,4328} (diff)
downloadgentoo-ed9829038751fab208ed07a97a35fa3168edae93.tar.gz
gentoo-ed9829038751fab208ed07a97a35fa3168edae93.tar.bz2
gentoo-ed9829038751fab208ed07a97a35fa3168edae93.zip
app-editors/vim-core: fix conflicts in 8.2.{4285,4328}
We fixed defaults.vim installation conflicts in e4c6279825a758f660237211dfcdfd83399887f4, but not for 8.2.4285 and 8.2.4328. Fix the issue for the versions. Bug: https://bugs.gentoo.org/830177 Signed-off-by: Dongsu Park <dpark@linux.microsoft.com> Closes: https://github.com/gentoo/gentoo/pull/24247 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim-core/vim-core-8.2.4285.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-8.2.4328.ebuild10
2 files changed, 14 insertions, 6 deletions
diff --git a/app-editors/vim-core/vim-core-8.2.4285.ebuild b/app-editors/vim-core/vim-core-8.2.4285.ebuild
index bfac57e4caa8..eda637ba36f0 100644
--- a/app-editors/vim-core/vim-core-8.2.4285.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.4285.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-8.2.4328.ebuild b/app-editors/vim-core/vim-core-8.2.4328.ebuild
index bfac57e4caa8..eda637ba36f0 100644
--- a/app-editors/vim-core/vim-core-8.2.4328.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.4328.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it