summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 09:26:40 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 14:44:07 +0100
commited9a66fa2080a99b70f9198affe0a4ea34d22585 (patch)
tree26f0c7a048a5c3c24b37303d5061d7d7d5141782
parentdev-libs/libpeas: Drop old (diff)
downloadgentoo-ed9a66fa2080a99b70f9198affe0a4ea34d22585.tar.gz
gentoo-ed9a66fa2080a99b70f9198affe0a4ea34d22585.tar.bz2
gentoo-ed9a66fa2080a99b70f9198affe0a4ea34d22585.zip
media-gfx/eog-plugins: Version bump
Package-Manager: portage-2.2.24
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.16.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 776489ee1a5d..4f45629fa7b7 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,2 +1,3 @@
DIST eog-plugins-3.16.1.tar.xz 368652 SHA256 c586b6708064dcd03612f9373a6160214b2fa4797bf8c07db530b18eda4074d9 SHA512 f7871cd99e54f65796c659d69bb1f741a706c243c2f0683c6efe38ae685a1a5b66a31a1dcb2bcea84a516b385a16c4d871ad78ebfa043dc8f895729d07758429 WHIRLPOOL 2a564c7e53eaf6daf283daa34845021eac3dbb30625dc307d749aab3a92f7e9cebed168af1d7d7f23bdeaa53ada957b448341fa97708ea57e5005dd024e4614c
DIST eog-plugins-3.16.2.tar.xz 369252 SHA256 f33de3c78d6a7d8a89441daa9c3e49e043dcdc527b0b7d477f0bf2d3af08e534 SHA512 4791946a86880844b87a1e6dd0fe7755e1e4dc2558d18e3df2e9410a355224de9787efb0cea9fc8c843ec9c11a907f90d5902fddc093f1af671c9cee20d45fe5 WHIRLPOOL 3252ab0dadf2fb0bc7b161cf56018f51136dd2195aef2f2755218f9d614f7b13766c5002981d1562ec5d383afb9a125afa2a464569d2289cb996d26119e57c63
+DIST eog-plugins-3.16.3.tar.xz 370528 SHA256 2d2198ed026b1c28329ac3d353b3031c2024277d81d60f3c1e626f4701a73bd2 SHA512 1ab8840147eadce718af9c8a7a5a9ddd99a30316ffbe31b57b24d8aa34e9908d83f95ed42e9ddc9368ebcc3eb8ea6e371232be8a015a771964178b02e7eb79b9 WHIRLPOOL efb351a9fbc9386bd527c4a0e9e9f3fb14274e1f129cd71bddb4e36132d5f4fbdf797d2bf962e442d6b2388c0ec219f52a9a588be99d0f124626e16633a54aa0
diff --git a/media-gfx/eog-plugins/eog-plugins-3.16.3.ebuild b/media-gfx/eog-plugins/eog-plugins-3.16.3.ebuild
new file mode 100644
index 000000000000..500c9c8179f6
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.16.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif +flickr map +picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ flickr? ( media-gfx/postr )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use flickr && plugins="${plugins},postr"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}