summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-05-25 19:06:23 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-05-25 20:26:53 -0500
commiteda33279083369e2c6a48e53f40f11dc5707a5d8 (patch)
tree87e49f9003cd7ec9f613d80afee3be27eef8128f
parentsci-mathematics/petsc: add 3.17.1 (diff)
downloadgentoo-eda33279083369e2c6a48e53f40f11dc5707a5d8.tar.gz
gentoo-eda33279083369e2c6a48e53f40f11dc5707a5d8.tar.bz2
gentoo-eda33279083369e2c6a48e53f40f11dc5707a5d8.zip
sci-mathematics/slepc: add 3.17.1
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-mathematics/slepc/Manifest1
-rw-r--r--sci-mathematics/slepc/slepc-3.17.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-mathematics/slepc/Manifest b/sci-mathematics/slepc/Manifest
index fad6e5f3c24b..cf9e24f3d0a5 100644
--- a/sci-mathematics/slepc/Manifest
+++ b/sci-mathematics/slepc/Manifest
@@ -2,3 +2,4 @@ DIST slepc-3.13.1.tar.gz 4797627 BLAKE2B 29372b8a2d4c5f3b26e840df743f7aec098bfee
DIST slepc-3.14.2.tar.gz 4865497 BLAKE2B d6fd0b45368383fad03b17f9d7f0ef26215b7459a5566c62ab2ad758eaa5fbc626be255b0aafa29b8830eb649a7bcfb0f36d383b865b4c1baa9de6037638de84 SHA512 0727a4f1672c4eb3cf0aa20aa408b897425539ac69123001ac3b2e0bc2d1fa230ef028fa0cd5e89e7a86a98884164fd1c97a742f90f0c128fcc7066d032ee321
DIST slepc-3.15.0.tar.gz 5191730 BLAKE2B 2fcdfbe25f59a80390478059ef0a8b066ac39b57e99fe65ab4fe4814507fdc78d1feb245df5f7542f08c151d20f2e2a6168c4bc2624f78ab5058627816bb6696 SHA512 f815f0805db3f3e329324778c172ba301ebb5d2fc8f8f4c5dd17e574a2cbed5c0f8015715bc908dfcbd4050fade8dab7ae3b312bae746c41d84c57bc5d101929
DIST slepc-3.16.0.tar.gz 5486237 BLAKE2B 28f45036ba7e6aa2b227c6f25e2c8edf7fc6914f3150043a7e310f270d24e669f32172897b558687c33a809c484e314a865296d4879a622d85004d329ec3bd1c SHA512 15ba9e4626fe3cf44142448b77869fa6d313bb7c026736d5552dfbab1ce350c2e2f2379fb647a1c236af8cb95895e4442dca1defa741a5b2b9172cbdf0baf75f
+DIST slepc-3.17.1.tar.gz 5450177 BLAKE2B ec4f597085a176a010797d599779cc4532e52996105bb76f755073876ebb81026c580cb5759a03bda58cb2de2767b1dcdb01ff0d946f218117edb2a7a6557414 SHA512 5429aa7516ec0b2fee8158f9317634faf1c963aa60237be81a0392d5f2fa9f531db59b4a9ad04e266d808befdbd71b5a30259b4abc639a1da2defffd74acd35b
diff --git a/sci-mathematics/slepc/slepc-3.17.1.ebuild b/sci-mathematics/slepc/slepc-3.17.1.ebuild
new file mode 100644
index 000000000000..8aa85eac9d58
--- /dev/null
+++ b/sci-mathematics/slepc/slepc-3.17.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
+HOMEPAGE="https://slepc.upv.es/"
+SRC_URI="https://slepc.upv.es/download/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="complex-scalars doc mpi"
+
+RDEPEND="
+ =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
+ sci-libs/arpack[mpi=]
+ mpi? ( virtual/mpi )
+"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+
+MAKEOPTS="${MAKEOPTS} V=1"
+
+src_configure() {
+ # *sigh*
+ addpredict "${PETSC_DIR}"/.nagged
+
+ # Make sure that the environment is set up correctly:
+ unset PETSC_DIR
+ unset PETSC_ARCH
+ source "${EPREFIX}"/etc/env.d/99petsc
+ export PETSC_DIR
+ export PETSC_ARCH
+ export SLEPC_DIR="${S}"
+
+ # configure is a custom python script and doesn't want to have default
+ # configure arguments that we set with econf
+ ./configure \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
+ --with-arpack=1 \
+ --with-arpack-lib="$(usex mpi "-lparpack,-larpack" "-larpack")"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # add PETSC_DIR to environmental variables
+ cat >> 99slepc <<- EOF
+ SLEPC_DIR=${EPREFIX}/usr/$(get_libdir)/slepc
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/slepc/lib
+ EOF
+ doenvd 99slepc
+
+ if use doc ; then
+ dodoc docs/slepc.pdf
+ docinto html
+ dodoc -r docs/*.html docs/manualpages
+ fi
+}