summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-27 08:14:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-27 08:19:42 +0100
commitedb0e9319b562b9c23031d7824ffe64c49c685ab (patch)
treec1ef7ec0a550e67b6a404d78ce6ff23fb4183f47
parentdev-python/pip: Add missing test dep on tomli-w (diff)
downloadgentoo-edb0e9319b562b9c23031d7824ffe64c49c685ab.tar.gz
gentoo-edb0e9319b562b9c23031d7824ffe64c49c685ab.tar.bz2
gentoo-edb0e9319b562b9c23031d7824ffe64c49c685ab.zip
dev-python/pip: Disable tests requiring tomli-w in stable cand.
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip/pip-21.3.1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/pip/pip-21.3.1.ebuild b/dev-python/pip/pip-21.3.1.ebuild
index f29173c59434..c84ad3111d15 100644
--- a/dev-python/pip/pip-21.3.1.ebuild
+++ b/dev-python/pip/pip-21.3.1.ebuild
@@ -90,6 +90,12 @@ python_test() {
tests/functional/test_install.py::test_editable_install__local_dir_setup_requires_with_pyproject
)
+ local EPYTEST_IGNORE=(
+ # require tomli-w that needs to be keyworded (added in -r1)
+ tests/functional/test_pep517.py
+ tests/functional/test_pep660.py
+ )
+
[[ ${EPYTHON} == python3.10 ]] && deselect+=(
tests/lib/test_lib.py::test_correct_pip_version
# uses vendored packaging that uses deprecated distutils