summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2022-06-10 15:01:54 +0800
committerWANG Xuerui <xen0n@gentoo.org>2022-06-24 13:12:10 +0800
commitedb166c13cd137717b9fbc06dc35ff7c79fed785 (patch)
treeac01b6f47368fd51b102447d99e978a7727d5091
parentkde-apps/kdepim-meta: Keyword 22.04.2 ppc64, #840683 (diff)
downloadgentoo-edb166c1.tar.gz
gentoo-edb166c1.tar.bz2
gentoo-edb166c1.zip
sys-kernel/linux-headers: add 5.19_rc1
While we can certainly wait for the official 5.19 release, adding this facilitates early loong testing across a wide variety of packages, because 5.19 is the earliest Linux version with upstreamed loong support. IUSE=experimental-loong is dropped while at it. This package will be replaced with the proper 5.19 release once that one is officially out. This is ~loong-only, because there isn't significant changes for other arches. Reviewed-by: Sam James <sam@gentoo.org> Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
-rw-r--r--sys-kernel/linux-headers/Manifest1
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.19_rc1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/Manifest b/sys-kernel/linux-headers/Manifest
index 09d45895a920..83f132bebced 100644
--- a/sys-kernel/linux-headers/Manifest
+++ b/sys-kernel/linux-headers/Manifest
@@ -23,3 +23,4 @@ DIST linux-5.18.tar.xz 129790264 BLAKE2B e2745a69eb70169e90505a9318a3993046eab30
DIST linux-5.4.tar.xz 109441440 BLAKE2B 193bc4a3147e147d5529956164ec4912fad5d5c6fb07f909ff1056e57235834173194afc686993ccd785c1ff15804de0961b625f3008cca0e27493efc8f27b13 SHA512 9f60f77e8ab972b9438ac648bed17551c8491d6585a5e85f694b2eaa4c623fbc61eb18419b2656b6795eac5deec0edaa04547fc6723fbda52256bd7f3486898f
DIST linux-loongarch-next-on-5.17-20220423.tar.xz 177296 BLAKE2B 947fd8c2192fe454beb346ea700a09a711f629d87cc5ff5b5d882fa1d57bb5e918fea821f5eddd44152812502479f853527b8317176326f8926bd1a532666a86 SHA512 b18df78802c2718181da95fdd5f83761bec7fced16b0aec05d00dcbd9b5c25fc0f84fbdd7e3b3fa5a3f78aea66e268dde3d9272a3f921b595b16270623ae0b7e
DIST linux-loongarch-next-on-5.18-20220523.tar.xz 160468 BLAKE2B ccb6df7fbee86fba7ae725362efeb03cdf4187cf877a7f21e470639c14509214ed31c06434207950b219d34ed41a9fd2be0b711faeb5c6c02198836f06ef7dce SHA512 d87b667947a1d41fbea6db80dc2896c2c7e297bac471b99820b10a4d1e8a680f3566a89bdb4e70c0bdfba335ce158f3e82f930eb2f6b64fd6ba736028bf709f2
+DIST patch-5.19-rc1.patch 90995640 BLAKE2B 0042e0a588fb4fa43259373e7c251e0f17f7640994d88bd1b27f73388a9a7a3229e03edc194f0cb719b9505fff651c7c9a4119c4f616040b35af7e500afd8d36 SHA512 bb2614786eecee03e38742a32dfbffce2b08881d35f51222dec88f9cec584eb1b60f3751e35f1a354124a162d443f0a4e345f6ee0193cebc29bc7ae5abb89003
diff --git a/sys-kernel/linux-headers/linux-headers-5.19_rc1.ebuild b/sys-kernel/linux-headers/linux-headers-5.19_rc1.ebuild
new file mode 100644
index 000000000000..273a2dcf6359
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-5.19_rc1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 loong m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
+K_BASE_VER="5.18"
+inherit kernel-2
+detect_version
+
+#PATCH_PV=${PV} # to ease testing new versions against not existing patches
+PATCH_PV="${K_BASE_VER}"
+PATCH_VER="1"
+PATCH_DEV="sam"
+SRC_URI="${KERNEL_URI}
+ ${PATCH_VER:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/sys-kernel/linux-headers/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}"
+S="${WORKDIR}/linux-${K_BASE_VER}"
+
+# this is an rc version, for testing on loong only
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~loong"
+
+BDEPEND="app-arch/xz-utils
+ dev-lang/perl"
+
+# bug #816762
+RESTRICT="test"
+
+[[ -n ${PATCH_VER} ]] && PATCHES=( "${WORKDIR}"/${PATCH_PV} )
+
+src_unpack() {
+ # avoid kernel-2_src_unpack
+ default
+}
+
+src_prepare() {
+ # TODO: May need forward porting to newer versions
+ use elibc_musl && PATCHES+=(
+ "${FILESDIR}"/${PN}-5.10-Use-stddefs.h-instead-of-compiler.h.patch
+ "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
+ )
+
+ # avoid kernel-2_src_prepare
+ default
+}
+
+src_test() {
+ emake headers_check ${xmakeopts}
+}
+
+src_install() {
+ kernel-2_src_install
+
+ find "${ED}" \( -name '.install' -o -name '*.cmd' \) -delete || die
+ # delete empty directories
+ find "${ED}" -empty -type d -delete || die
+}