summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 21:24:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 21:24:33 +0200
commitedb4b557337a97215890f00cdbe4e5ce074ab3fd (patch)
tree0d5a37682a1e227cb7bddc7ee320e9cbef2f4eaa
parentxfce-extra/xfce4-time-out-plugin: Bump to 1.1.3 (diff)
downloadgentoo-edb4b557337a97215890f00cdbe4e5ce074ab3fd.tar.gz
gentoo-edb4b557337a97215890f00cdbe4e5ce074ab3fd.tar.bz2
gentoo-edb4b557337a97215890f00cdbe4e5ce074ab3fd.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index f5c779352fab..6d806913bd1c 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-weather-plugin-0.11.0.tar.bz2 3019896 BLAKE2B 3ab8c2d16efb47f921ad5b6511428545553959fec52973f0735706d42b8b260c10f6a1be6db56e9b6f02bca75eaf41d8543be6ac3afd7bb1e44a75d9b6615ff3 SHA512 f4534d47f825358752ec6252fd0fc49a44ac682e4cdce960d744cd343f5f670473fa4175c59849282352dc75ca9b22b83d7ace68cedfc7dc89bcb21be24ccf86
+DIST xfce4-weather-plugin-0.11.1.tar.bz2 3100215 BLAKE2B 454fd3d4f1d40123b4ffd6f648b43079be444fccb876e123604deeee51741819ab3b65d81e56af9f25dce720f34d706f6c87211619a8e55b7f9f41bb5fc530e1 SHA512 625b2aab1ded60eb39171969cd67224569cf7477c0a6e47aa5600a4a09b4a2cecd4b830f4c01669e6f2289edd4e7d882b15d56526a1211b8b5b86141b585778f
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild
new file mode 100644
index 000000000000..c16e116d9447
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-weather-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-weather-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="upower"
+
+DEPEND="
+ >=dev-libs/glib-2.50
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.42:2.4[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.12:=
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}