summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-27 12:35:04 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-27 13:04:45 +0200
commitedb5b0d9077a5977148994285fb926ae3d4ff341 (patch)
tree5bdcff56e59979b18941799d1eff2234bce61ecc
parentdev-util/opencl-headers: drop 2020.03.13-r1 (diff)
downloadgentoo-edb5b0d9077a5977148994285fb926ae3d4ff341.tar.gz
gentoo-edb5b0d9077a5977148994285fb926ae3d4ff341.tar.bz2
gentoo-edb5b0d9077a5977148994285fb926ae3d4ff341.zip
dev-vcs/pre-commit: drop 2.12.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.12.0.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 96abbe1d8c19..b94fd505fbe6 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,2 +1 @@
-DIST pre-commit-2.12.0.tar.gz 246269 BLAKE2B a697cc0287e0cd5698d78056cd51484115788fc22ab36d951e3f390efad881353ed10a39f04fbfda78c163f2eb67357d6b0050d2a34d79fcb4c3495b9eab6046 SHA512 b65dab5dade2186785b2065d9d73427836a61acc3b2efcf54e74313361dcdb89c7ec829a1f653a4491afbe78d11cd4ed640ca579e7d2ca383daeb9680867812d
DIST pre-commit-2.12.1.tar.gz 246313 BLAKE2B 45ee7c8217f88eeaa2e9eb11efd79291d6577134799b328f252bd4d4283c11754b36ffeedf045a5101c6edc8cdf330d566e404ae34f1a831a830e8e0346337e9 SHA512 6dbd804e1001276e6e8cea7c31b321a05798b38c59f37d5900317c3a9ceccf5103afcbdfd29f9438be3595a18ae15eb09dd222c91c439da47d7728a0e0a55c70
diff --git a/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
deleted file mode 100644
index 5a4c4ea945f6..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# TODO: figure out why these tests - all of which invoke git - fail:
-# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall]
-# "Git failed", not much information beyond that
-# - tests/main_test.py::test_try_repo
-# Ditto
-# - tests/commands/install_uninstall_test.py::test_installed_from_venv
-# "git commit" returns 1 instead of 0, again no details
-RESTRICT="test"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- dev-python/cfgv[${PYTHON_USEDEP}]
- dev-python/identify[${PYTHON_USEDEP}]
- dev-python/nodeenv[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- default
-
- # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
- rm -rf tests/languages tests/repository_test.py
-}