summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-11-07 12:58:52 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-11-07 13:37:07 +0100
commitedc6326daec401769f323417268d1567c8817609 (patch)
tree59a43f16654c7d722f3d4fd29a7af1fc06eb85ea
parentdev-lua/mpack: readd riscv keyword (diff)
downloadgentoo-edc6326d.tar.gz
gentoo-edc6326d.tar.bz2
gentoo-edc6326d.zip
dev-libs/mxml: bump to version 3.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-libs/mxml/Manifest1
-rw-r--r--dev-libs/mxml/mxml-3.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index 6a17f8cd6e27..5e6f1890a14e 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1 +1,2 @@
DIST mxml-3.2.tar.gz 9267930 BLAKE2B f244dab599233b8a26aba5a11526979bf2f4d20b5fce67858f7759abc5bd2f3e2aac19d512c887248839d130cf1314065687cd1ccf91edbf5533ae2d342f286b SHA512 ed3f2b361394ef225a708b0032976a3d191d5eaea3022e190b29e0ee140e8f998f1d65c64e4898872b169516cee44f4f5f18401c6410c3b5aa1e9680b23e8675
+DIST mxml-3.3.tar.gz 1550358 BLAKE2B 2b815cd8c2031099e2767caad93cc389962ec547fadade92b0a7fb48a2352fd0940c9e434c2081b7419e0cfb489266d7116dacefd6fb9d7ce40d6de0f49cb2a6 SHA512 5a8453bec17e46afc9b100df03dba2219353a076152f34a5dc41b7f042fa570723effc3472680a4380674c412c3ab31e017f6704b1e8308227a4d9b3f13cb197
diff --git a/dev-libs/mxml/mxml-3.3.ebuild b/dev-libs/mxml/mxml-3.3.ebuild
new file mode 100644
index 000000000000..a0e3cdb5191b
--- /dev/null
+++ b/dev-libs/mxml/mxml-3.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs threads"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+
+ # Build only static-libs, when requested by user, also build docs without static-libs in that case
+ if ! use static-libs; then
+ local mysedopts=(
+ -e '/^install:/s/install-libmxml.a//g'
+ -e '/^mxml.xml:/s/-static//g'
+ -e '/^mxml.epub:/s/-static//g'
+ -e '/^valgrind/s/-static//g'
+ -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
+ )
+ sed "${mysedopts[@]}" -i Makefile.in || die
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake testmxml
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}