summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-09 22:20:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-09 22:23:22 +0200
commitedc8e716cb50cb3f0f026925677571811211afd0 (patch)
tree39a412275cf997b529565585f09c1fbe4d11515e
parentdev-python/zope-schema: PEP517, remove namespace dep (diff)
downloadgentoo-edc8e716cb50cb3f0f026925677571811211afd0.tar.gz
gentoo-edc8e716cb50cb3f0f026925677571811211afd0.tar.bz2
gentoo-edc8e716cb50cb3f0f026925677571811211afd0.zip
dev-python/zope-testing: Remove namespace pkg dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zope-testing/zope-testing-4.10-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/zope-testing/zope-testing-4.10-r1.ebuild b/dev-python/zope-testing/zope-testing-4.10-r1.ebuild
new file mode 100644
index 000000000000..0ad39021764d
--- /dev/null
+++ b/dev-python/zope-testing/zope-testing-4.10-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope testing helpers"
+HOMEPAGE="
+ https://pypi.org/project/zope.testing/
+ https://github.com/zopefoundation/zope.testing/
+"
+SRC_URI="mirror://pypi/${P::1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ # this is needed to keep the tests working while
+ # dev-python/namespace-zope is still installed
+ cat > zope/__init__.py <<-EOF || die
+ __path__ = __import__('pkgutil').extend_path(__path__, __name__)
+ EOF
+ eunittest
+ rm zope/__init__.py || die
+}