summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 17:11:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 17:27:41 +0100
commitedf3fccae6bccc45a6bd6061fab6285093c8b7a2 (patch)
treebaf75b11856fbec8d8b827e9cca77ac3c317a362
parentdev-python/ropemode: Enable py3.12 (diff)
downloadgentoo-edf3fccae6bccc45a6bd6061fab6285093c8b7a2.tar.gz
gentoo-edf3fccae6bccc45a6bd6061fab6285093c8b7a2.tar.bz2
gentoo-edf3fccae6bccc45a6bd6061fab6285093c8b7a2.zip
dev-python/reedsolo: Recythonize & enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/reedsolo/reedsolo-2.1.1_beta1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/reedsolo/reedsolo-2.1.1_beta1-r2.ebuild b/dev-python/reedsolo/reedsolo-2.1.1_beta1-r2.ebuild
new file mode 100644
index 000000000000..1e6983bad4e2
--- /dev/null
+++ b/dev-python/reedsolo/reedsolo-2.1.1_beta1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python Reed Solomon encoder/decoder"
+HOMEPAGE="
+ https://github.com/tomerfiliba-org/reedsolomon/
+ https://pypi.org/project/reedsolo/
+"
+
+LICENSE="|| ( Unlicense MIT-0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/pytest-cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ local DISTUTILS_ARGS=()
+ if use native-extensions && [[ ${EPYTHON} != pypy3 ]] ; then
+ DISTUTILS_ARGS+=(
+ # TODO: switch to --cythonize once we're on cython-3
+ --cythonize
+ )
+ fi
+ distutils-r1_python_compile
+}