summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 08:20:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:28 +0100
commitedf4715e1799822f1b2df3625c54c2d23f816930 (patch)
tree9102d3b77ea82a10d27b9a2ae1890b0357085594
parentdev-python/python-cstruct: Remove old (diff)
downloadgentoo-edf4715e.tar.gz
gentoo-edf4715e.tar.bz2
gentoo-edf4715e.zip
dev-python/python-cstruct: Bump to 4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-cstruct/Manifest1
-rw-r--r--dev-python/python-cstruct/python-cstruct-4.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 0caaecb913bc..fe4e952644c2 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1 +1,2 @@
DIST python-cstruct-3.3.gh.tar.gz 27470 BLAKE2B 0403af7085622e26d5faf973bbfd0c7e35f5c51f0597abf079080800055058809a07a795bde37b796809ef13b6e1d030f36a42e45a7f4643202e37fe79df4730 SHA512 fd5d7d42f5458d37a44d5e792b56e5c4f3338ed656b248ec5f4f48e4ecb5b6be7e3561c697d67ce0c6a18fbef62ba4945e287754cb2d6a97fefd65c563d65774
+DIST python-cstruct-4.0.gh.tar.gz 28370 BLAKE2B 48f750849d332d03f1d6424a6c6f5146efacb6af05c82040dd7c39c701fbebb60dbc324db395dbd918ac5b677c63d541f00de871eb47c73b3f56e8aab08d8ff1 SHA512 e8c1345f06ca23bc19bbfad569b9822369eec8957eac504191dbd34f9c4e8197a4150e73d2ae3881b7e9fbf288c81cf320872aaefec8e8e80385e4ea473242c7
diff --git a/dev-python/python-cstruct/python-cstruct-4.0.ebuild b/dev-python/python-cstruct/python-cstruct-4.0.ebuild
new file mode 100644
index 000000000000..ac6eadb21a2a
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="
+ https://github.com/andreax79/python-cstruct/
+ https://pypi.org/project/cstruct/
+"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "/find_packages(/s@exclude=\[@&'tests', @" -i setup.py || die
+}