summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-02-23 03:02:14 +0530
committerSam James <sam@gentoo.org>2024-03-21 02:18:45 +0000
commitedfeb8763ac56112c59248c62c9cda13e5d01c97 (patch)
tree45d5af2557dadc6be8bb13f551da1c1936a2c460
parentdev-util/nihtest: add 1.5.2 (diff)
downloadgentoo-edfeb8763ac56112c59248c62c9cda13e5d01c97.tar.gz
gentoo-edfeb8763ac56112c59248c62c9cda13e5d01c97.tar.bz2
gentoo-edfeb8763ac56112c59248c62c9cda13e5d01c97.zip
net-misc/passt: add 2024.03.20 and bug fixes
Closes: https://bugs.gentoo.org/920795 Closes: https://bugs.gentoo.org/924494 Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35500 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/passt/Manifest1
-rw-r--r--net-misc/passt/files/Makefile-2024.03.20.patch13
-rw-r--r--net-misc/passt/passt-2024.03.20.ebuild40
-rw-r--r--net-misc/passt/passt-9999.ebuild15
4 files changed, 67 insertions, 2 deletions
diff --git a/net-misc/passt/Manifest b/net-misc/passt/Manifest
index a8aab82353a4..2a3c232940c4 100644
--- a/net-misc/passt/Manifest
+++ b/net-misc/passt/Manifest
@@ -1,2 +1,3 @@
DIST passt-2023.12.04.tar.xz 188136 BLAKE2B f1d72fbb4bbb25f6a11e9ff87a91cf9bac06e047b8cb9a8b40402ced1422c23b105fa7e64646698d38ad747efa449c34cfdaecf492a3e4984114cbcf60656cdc SHA512 febd9fa22363438b52b2688481183d81c22966e1775139fc559dbfa50437c9b00ba09800db867738d25fcea8ac05d4589b75dcd2d0c88eeffefc0598d4236001
DIST passt-2023.12.30.tar.xz 188596 BLAKE2B 75712a7cb7a00fea20427979153090d938b8c7b0e3da61c83cabb3751786034df35ebbe8afbd991d582a680f55b12792547b68efa931a5576dc181040b31e5fd SHA512 4b19d191e2526bacc61bb8ab2964f5da4e0535656b094a7592f91d6b437c855a586fc772e2abd89138ff4f89aae12ade494c6e0fe7bee1502fe319215200d8f0
+DIST passt-2024.03.20.tar.xz 195332 BLAKE2B 1bed740ddd235f300a4233fb2024f155758809589f1fdd2174ab99a8a93dd16044ab41814b215d12eb1e557966a73a3754bbff2b9acd752b45b385edd88ba3c7 SHA512 3701820e539545771d0f867fe0b8977cb5967e7501413f717fed08d2d2c141f17d86ed7238177b4fb4cf4cfc01c6c9d07e3c218c34b48e0a5a1f2b2ce8a5b903
diff --git a/net-misc/passt/files/Makefile-2024.03.20.patch b/net-misc/passt/files/Makefile-2024.03.20.patch
new file mode 100644
index 000000000000..30f36d1f084d
--- /dev/null
+++ b/net-misc/passt/files/Makefile-2024.03.20.patch
@@ -0,0 +1,13 @@
+Addressing following bugs:
+https://bugs.gentoo.org/924494
+--- a/Makefile
++++ b/Makefile
+@@ -35,7 +35,7 @@
+
+ FLAGS := -Wall -Wextra -Wno-format-zero-length
+ FLAGS += -pedantic -std=c11 -D_XOPEN_SOURCE=700 -D_GNU_SOURCE
+-FLAGS += -D_FORTIFY_SOURCE=2 -O2 -pie -fPIE
++FLAGS += -O2 -pie -fPIE
+ FLAGS += -DPAGE_SIZE=$(shell getconf PAGE_SIZE)
+ FLAGS += -DNETNS_RUN_DIR=\"/run/netns\"
+ FLAGS += -DPASST_AUDIT_ARCH=AUDIT_ARCH_$(AUDIT_ARCH)
diff --git a/net-misc/passt/passt-2024.03.20.ebuild b/net-misc/passt/passt-2024.03.20.ebuild
new file mode 100644
index 000000000000..effdc66105d0
--- /dev/null
+++ b/net-misc/passt/passt-2024.03.20.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
+HOMEPAGE="https://passt.top/"
+
+RELEASE_COMMIT="71dd405"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://passt.top/passt"
+else
+ SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="static"
+
+PATCHES=(
+ "${FILESDIR}"/Makefile-2024.03.20.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ [[ ${PV} != 9999* ]] && export VERSION="${PV}"
+ export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
+
+ emake $(usev static)
+}
diff --git a/net-misc/passt/passt-9999.ebuild b/net-misc/passt/passt-9999.ebuild
index 5683bd6f8693..effdc66105d0 100644
--- a/net-misc/passt/passt-9999.ebuild
+++ b/net-misc/passt/passt-9999.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit toolchain-funcs
+
DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
HOMEPAGE="https://passt.top/"
-RELEASE_COMMIT="b86afe3"
+RELEASE_COMMIT="71dd405"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -21,6 +23,15 @@ LICENSE="BSD GPL-2+"
SLOT="0"
IUSE="static"
+PATCHES=(
+ "${FILESDIR}"/Makefile-2024.03.20.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
src_compile() {
[[ ${PV} != 9999* ]] && export VERSION="${PV}"
export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"