summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-24 05:07:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-24 05:07:14 +0200
commitee1f5640353565d13ad9b13f52adffbf6dfb66d1 (patch)
tree71e3d43b2562912e3d640c0e689e42c32d5f4ce0
parentdev-python/pytest-xprocess: Bump to 0.23.0 (diff)
downloadgentoo-ee1f5640.tar.gz
gentoo-ee1f5640.tar.bz2
gentoo-ee1f5640.zip
dev-python/argh: Bump to 0.29.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.29.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index 620921cd65db..6418fc11876c 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1,2 +1,3 @@
DIST argh-0.28.1.tar.gz 62511 BLAKE2B fb06ad73c5d8e8508103007a2213285f52f4d245ade288504616d42847c982a27ca94f0850f87052737c17740de705a9f8557fcafbea6f656e30ca1ed99efffb SHA512 c5d4515f5ba94a60dbcc6fa81812c192b51539ceee349129028a3d736ba1b0eac23135b31fa6d350e9fff778250365848e6c2077553849aeebbb9b67be6774dc
DIST argh-0.29.3.tar.gz 52641 BLAKE2B c9cdfbf9a958ce6386984c422717cf9dbcdf6bf69a909e34fcc34a3b6cc3e8f9ee831898fb1fbe39cef68927a949d172b553fb51c16a7ae80382c03be0a26d57 SHA512 ec5c090399e824d0e6dc51b199859e40707d5a7f3b651ef72b186d8b3bf402096e9522b6eaf90bbaeb3ad58aae24c25f043749698c47e3fabbb6259e9b9dbffc
+DIST argh-0.29.4.tar.gz 52694 BLAKE2B 6d2b75200ea7b570ac199139ba7bc92b5bfa41fa4e21d19eff17d8506c4a28c6043413a25679cab52f9d81b8bb9a1f35b77ffee3beaa98c43660ad9e5c6b8dfc SHA512 017346afb237429de1228f604a763f919528fd359edfabb7b5a5c3a48c5e5be5a5a385672d54299cd15e5bc82257d8c33816fbc463873ffb9b3c3a54b40fccfc
diff --git a/dev-python/argh/argh-0.29.4.ebuild b/dev-python/argh/argh-0.29.4.ebuild
new file mode 100644
index 000000000000..32a100a7ba11
--- /dev/null
+++ b/dev-python/argh/argh-0.29.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest