summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-02-04 06:13:10 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-04 06:13:11 +0200
commitee3f77c3307b17ab929713ace39f8767f9031959 (patch)
treefb081b0214836ce843c05e76142e12a441f148f7
parentdev-util/byacc: remove old (diff)
downloadgentoo-ee3f77c3307b17ab929713ace39f8767f9031959.tar.gz
gentoo-ee3f77c3307b17ab929713ace39f8767f9031959.tar.bz2
gentoo-ee3f77c3307b17ab929713ace39f8767f9031959.zip
dev-libs/appstream-glib: bump to 0.6.8, fixes gperf 3.1 compat
Gentoo-bug: 604888 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.6.8.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index 96af931f831f..6daeb8a4ef91 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -2,3 +2,4 @@ DIST appstream-glib-0.5.0.tar.xz 1818388 SHA256 35d63ca31664918905c3de634766766d
DIST appstream-glib-0.6.3.tar.xz 1944512 SHA256 3ec355c950b86cd792b6e396a5a4a72487999e300fcacf7466a663974ec4ad24 SHA512 aae4885e32bc6f0247f6e8f415471531a8c28976e1ba4bd977200d72e24a04dfc2370395e3e0ea6e052386a963540cb91f025cd4f1ab837404762f1be2a76ff0 WHIRLPOOL 5bc9874e9f0708064f93fca8938d3708171dbf4cd356c8475e6d804ba109e51fc0b00d5dc4ac547f55c8a37c358c0d8fad6900ea214e8760b6da999be3f8c252
DIST appstream-glib-0.6.5.tar.xz 1948908 SHA256 b6b77540b03ca56d7a8493d5f50ded747b6033e0437d8e4c516b5228e27b2a1a SHA512 606befae4fd675757e276a13679e1355359179537e701c8b14bb0b0ef0f21105231f2fa1338ac7776faa649a076da3e83f5dcb77120d14bb3a8945aa2d8e1376 WHIRLPOOL 7cce5c75c8659f64a35ed01118b00468d00563b94ed26f3d467c1d875a9c768ede85dc635c5a6eff1c8aa7612decc67ff362c8b8cc6cef73a8ebf1c54a311054
DIST appstream-glib-0.6.7.tar.xz 1961284 SHA256 9767756e2c970709f0070d4c9e617bb3af2d62cd4fbce8486bd742092671b922 SHA512 cc8b58fa1eb8a4cb0c73f256ff3455d7ffc62282cf70676ae669a0b471c08278b3870d5d50dc70c386ec536031056136ba6742b674d94ca0c20d397f49615df2 WHIRLPOOL 93b8698d018eee7997b6fd232f8ee0447f34980628905147ae73b9274b2781fd422eca41ed266f89faee3ee63616cff86a12ca60e78d297ead56d462692534b7
+DIST appstream-glib-0.6.8.tar.xz 1962132 SHA256 23f009233a96d1246c4c46c9746be126ae9d422753399621445d07bff49cae41 SHA512 dac9e0cc6dd8dfb81cbcdb6796d6890b61d5ede634cbe31768d1cf5746ada3beaf8b46918bab24e72604d52cbf6c6602efa6aedbdf9379f4c10528929f926fe5 WHIRLPOOL d2f2dd1607f4cb03ab501e4e189862cbb5c58b0bc3e63af153d72c7a714e791509dc2981921b1414f11282f7681277b690cb3142ce71c2bacd2799a935bdfdc2
diff --git a/dev-libs/appstream-glib/appstream-glib-0.6.8.ebuild b/dev-libs/appstream-glib/appstream-glib-0.6.8.ebuild
new file mode 100644
index 000000000000..c0e5a9ff084f
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.6.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection nls stemmer"
+
+RDEPEND="
+ app-arch/gcab
+ app-arch/libarchive
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.45.8:2
+ >=dev-libs/json-glib-1.1.1
+ dev-libs/libyaml
+ >=media-libs/fontconfig-2.11:1.0
+ >=media-libs/freetype-2.4:2
+ >=net-libs/libsoup-2.51.92:2.4
+ sys-apps/util-linux
+ >=x11-libs/gdk-pixbuf-2.31.5:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+ stemmer? ( dev-libs/snowball-stemmer )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=sys-devel/gettext-0.19.7
+ dev-util/gperf
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-builder \
+ --enable-firmware \
+ --enable-fonts \
+ --disable-rpm \
+ --disable-static \
+ --enable-dep11 \
+ --enable-man \
+ $(use_enable nls) \
+ $(use_enable introspection) \
+ $(use_enable stemmer) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}