summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-29 18:14:27 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-01 19:42:24 +0200
commitee4b5cac5c7f24c7a016045f72ae64e5e48a21c0 (patch)
tree1a0020c6c1b7bb70fd3db71dd9acaf19535e4cf5
parentnet-libs/dleyna: Version bump to 0.8.3 (diff)
downloadgentoo-ee4b5cac.tar.gz
gentoo-ee4b5cac.tar.bz2
gentoo-ee4b5cac.zip
dev-cpp/cairomm: Version bump to 1.18.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33131 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-cpp/cairomm/Manifest1
-rw-r--r--dev-cpp/cairomm/cairomm-1.18.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/cairomm/Manifest b/dev-cpp/cairomm/Manifest
index 4a545f878c26..15ec5b166503 100644
--- a/dev-cpp/cairomm/Manifest
+++ b/dev-cpp/cairomm/Manifest
@@ -1,2 +1,3 @@
DIST cairomm-1.14.4.tar.xz 618548 BLAKE2B 611e05b66e731d470c6d9a64c2eb4aee68aa73be5c05cb7e741e9a851ef15609cfc9fc27177531880b16517e62cf5c3f7669d4f7e7c5c78b9bc7d829e27f4d25 SHA512 9e2692837f55a2e66cd7e9d0a8033a35524df1c3186a53a9be75d71e899240dbc8959c914471e61e311812dabaf815e732142686b42fbdc75a71c05b41013d33
DIST cairomm-1.16.2.tar.xz 593504 BLAKE2B 6682604f5907f16e40dd497f07eaaca5a4dc8a0b90771a0631406817ec397c42eb1784a6cbf15094ea6d61591acf04818e1b4d64ede3383b6859668d3b445a76 SHA512 61dc639eabe8502e1262c53c92fe57c5647e5ab9931f86ed51e657df1b7d0e3e58c2571910a05236cc0dca8d52f1f693aed99a553430f14d0fb87be1832a6b62
+DIST cairomm-1.18.0.tar.xz 632520 BLAKE2B e05135eb2e22ed6002821567dd951644febc173b04e001f3574d6dac36d0c6d012c3806e7485fa7856402945934c653c4546855a8e97b016130edac31726d827 SHA512 d358a765136e244773b4a0fdcb2d9c81dd0b76f7a27c7108f94df9765f2d790f5f50b5645c09c292efce3e012528f85114d51916450c5fe6fa87d09f5a405d4c
diff --git a/dev-cpp/cairomm/cairomm-1.18.0.ebuild b/dev-cpp/cairomm/cairomm-1.18.0.ebuild
new file mode 100644
index 000000000000..c551d96c7702
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.18.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson-multilib python-any-r1
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="https://cairographics.org/cairomm/ https://gitlab.freedesktop.org/cairo/cairomm"
+SRC_URI="https://www.cairographics.org/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.16"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="gtk-doc test X"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libsigc++:3[gtk-doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.14.10[X=,${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/boost[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? (
+ ${PYTHON_DEPS}
+ >=dev-cpp/mm-common-1.0.4
+ app-doc/doxygen[dot]
+ dev-libs/libxslt
+ )
+"
+
+pkg_setup() {
+ use gtk-doc && python-any-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool gtk-doc build-documentation)
+ -Dbuild-examples=false
+ $(meson_use test build-tests)
+ -Dboost-shared=true
+ )
+ meson_src_configure
+}