summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-31 07:58:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-31 08:17:25 +0100
commitee51c2eeffdddb3158f0c0ec61164c2c361adaf3 (patch)
tree72e20dd9c5f504931f862a945f83ef0d21c22e58
parentxfce-base/thunar: Bump to 4.18.10 (diff)
downloadgentoo-ee51c2eeffdddb3158f0c0ec61164c2c361adaf3.tar.gz
gentoo-ee51c2eeffdddb3158f0c0ec61164c2c361adaf3.tar.bz2
gentoo-ee51c2eeffdddb3158f0c0ec61164c2c361adaf3.zip
dev-python/pydot: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pydot/Manifest1
-rw-r--r--dev-python/pydot/pydot-2.0.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pydot/Manifest b/dev-python/pydot/Manifest
index cddb02660c60..91b87540c67e 100644
--- a/dev-python/pydot/Manifest
+++ b/dev-python/pydot/Manifest
@@ -1 +1,2 @@
DIST pydot-1.4.2.gh.tar.gz 272678 BLAKE2B 966f2c4ef3e26a63cc50ab89b5b6b5b413aabdfeddf994f2d5ba9dedaa1ed3152dd8060186e7380c3e768b783f7bfe1971cd600c18d1b73f7ac63db08ee3ace9 SHA512 caa8051561710129b5164fd1392da941829fd977092a6ec8b00efe7a199d2d60bc7ef13cb0e51615f384550f0fb80190d0f56b83d8d80d1fe372efb5dbbd3632
+DIST pydot-2.0.0.gh.tar.gz 275188 BLAKE2B 58f1598196861795bd44c6b97683e0c37b3c05e848a69d42a3fc898849f272466c989e7ff72e0be22a322a1e92c31c6b76a9317e56f3ec26743c20801daf8bfd SHA512 09102930a59ac4339e1d1e4f7a9d075f99eda6cb060885631a72f1fded90d001bd02940b55addc0c92856e95321cb3b344a1797b4809ac7c9048ac57c81d4707
diff --git a/dev-python/pydot/pydot-2.0.0.ebuild b/dev-python/pydot/pydot-2.0.0.ebuild
new file mode 100644
index 000000000000..4547bc0f8b06
--- /dev/null
+++ b/dev-python/pydot/pydot-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="
+ https://github.com/pydot/pydot/
+ https://pypi.org/project/pydot/
+"
+# pypi releases don't include tests
+SRC_URI="
+ https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd test || die
+ local -x PYTHONPATH="${BUILD_DIR}/install$(python_get_sitedir)"
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}