summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-03-14 17:34:08 +0100
committerSam James <sam@gentoo.org>2022-03-21 23:41:05 +0000
commitee5c9ab35b61b28d01c8ea267d0e7af4e3fbf34a (patch)
tree11ba313a5deabfe297121679db763eb215581ef9
parentsci-astronomy/wcslib: version bump 7.7 (diff)
downloadgentoo-ee5c9ab3.tar.gz
gentoo-ee5c9ab3.tar.bz2
gentoo-ee5c9ab3.zip
dev-libs/mimetic: fix musl build
Upstream-PR: https://github.com/tat/mimetic/pull/27 Closes: https://bugs.gentoo.org/712624 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/24585 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/mimetic/files/mimetic-0.9.8-uint-musl.patch36
-rw-r--r--dev-libs/mimetic/mimetic-0.9.8.ebuild3
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/mimetic/files/mimetic-0.9.8-uint-musl.patch b/dev-libs/mimetic/files/mimetic-0.9.8-uint-musl.patch
new file mode 100644
index 000000000000..45e90c0450e2
--- /dev/null
+++ b/dev-libs/mimetic/files/mimetic-0.9.8-uint-musl.patch
@@ -0,0 +1,36 @@
+From 6afcd2f85332bdb25e38718cb9db6e3040797a8f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20Van=C4=9Bk?= <arkamar@atlas.cz>
+Date: Sat, 12 Mar 2022 21:20:50 +0100
+Subject: [PATCH] Use unsigned int where uint is not defined
+
+Upstream-PR: https://github.com/tat/mimetic/pull/27
+
+diff --git a/mimetic/codec/other_codecs.h b/mimetic/codec/other_codecs.h
+index c4ccf3f..3e68dd9 100644
+--- a/mimetic/codec/other_codecs.h
++++ b/mimetic/codec/other_codecs.h
+@@ -109,7 +109,7 @@ struct MaxLineLen: public unbuffered_codec, public chainable_codec<MaxLineLen>
+ : m_max(0), m_written(0)
+ {
+ }
+- MaxLineLen(uint m)
++ MaxLineLen(unsigned int m)
+ : m_max(m), m_written(0)
+ {
+ }
+diff --git a/mimetic/contenttype.cxx b/mimetic/contenttype.cxx
+index 81c36c0..0cb75e7 100644
+--- a/mimetic/contenttype.cxx
++++ b/mimetic/contenttype.cxx
+@@ -34,7 +34,7 @@ ContentType::Boundary::Boundary()
+ stringstream ss;
+ srand(time(0));
+ short tbSize = sizeof(tb)-1;
+- for(uint i=0; i < 48; ++i)
++ for(unsigned int i=0; i < 48; ++i)
+ {
+ unsigned int r = rand();
+ ss << tb[r % tbSize];
+--
+2.34.1
+
diff --git a/dev-libs/mimetic/mimetic-0.9.8.ebuild b/dev-libs/mimetic/mimetic-0.9.8.ebuild
index da9c0be7544b..4717e99d7e02 100644
--- a/dev-libs/mimetic/mimetic-0.9.8.ebuild
+++ b/dev-libs/mimetic/mimetic-0.9.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,6 +19,7 @@ BDEPEND="doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}/signed-char.patch"
"${FILESDIR}/${P}-build-mmap.patch"
+ "${FILESDIR}/${P}-uint-musl.patch"
)
src_prepare() {