summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2021-11-16 10:03:02 +0200
committerStefan Strogin <steils@gentoo.org>2021-11-16 08:06:59 +0000
commitee601735af93825f6a1e7d693d0e9c67bc78a453 (patch)
treebc796551a706990c5d9e283227ed2331d1b4aecd
parentdev-games/mygui: upgrade to 3.4.1 (diff)
downloadgentoo-ee601735af93825f6a1e7d693d0e9c67bc78a453.tar.gz
gentoo-ee601735af93825f6a1e7d693d0e9c67bc78a453.tar.bz2
gentoo-ee601735af93825f6a1e7d693d0e9c67bc78a453.zip
dev-games/mygui: drop old 3.4.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--dev-games/mygui/Manifest1
-rw-r--r--dev-games/mygui/files/mygui-3.4.0-build.patch61
-rw-r--r--dev-games/mygui/files/mygui-3.4.0-underlinking.patch21
-rw-r--r--dev-games/mygui/mygui-3.4.0.ebuild159
4 files changed, 0 insertions, 242 deletions
diff --git a/dev-games/mygui/Manifest b/dev-games/mygui/Manifest
index 6d4d6c2c981b..907e4d1b27ed 100644
--- a/dev-games/mygui/Manifest
+++ b/dev-games/mygui/Manifest
@@ -1,3 +1,2 @@
DIST MyGUI3.2.2.tar.gz 22081236 BLAKE2B 3a28e0838a8203d20565822d5a19423a733149cca250dc4169de43f22beb7d37fccbf3d282ea9b4f284cb71df2df9a9073bac40124e1d8a90d15c5fda2af798a SHA512 1290ce1d78b9e4bfe72bea3fb1bc6cdd25969b44be2844df62a1f425b3e221a68b61658fdf45271fb50a1957f12b5ada1c9be971e00ecfe41f53ae0a83ae18d4
-DIST mygui-3.4.0.tar.gz 22391483 BLAKE2B 5628cca98625285368b9363acd95e541e1ba7d86fd1d471f687c553d0f0abd9ccb2f47981cf0bb91f44a68489bb7ec3fbcb451734758e2435ab9ef320214465a SHA512 3f560fd9c7e5b514da40e41c7753dc20649f80b763f5ee20afc9627df3be14242ea833eff09eac16b9e88b1c9fbed7c09def0c5068c832e710c247191fb53487
DIST mygui-3.4.1.tar.gz 22433198 BLAKE2B 400f88a63df1bff5554236a0aeb58218fdb6100aa84f9eb1ac111adabfa45ae7eb1c3124bb04f3ef57587566e716d3242daa9cb5866d7ccc43a56c9605952411 SHA512 9d36272345b1a755db88848c8a0919feb6f8ae09d048efa3b8ed833bb5ddb9c65e1e7e0d26ad39eecd2a4de53fb654f4099c555e9ebd21ce9541a1a74580ef05
diff --git a/dev-games/mygui/files/mygui-3.4.0-build.patch b/dev-games/mygui/files/mygui-3.4.0-build.patch
deleted file mode 100644
index 71ed87d8bcb8..000000000000
--- a/dev-games/mygui/files/mygui-3.4.0-build.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/CMake/ConfigureBuild.cmake b/CMake/ConfigureBuild.cmake
---- a/CMake/ConfigureBuild.cmake
-+++ b/CMake/ConfigureBuild.cmake
-@@ -4,6 +4,8 @@
- # also prepare package files for pkg-config and CMake.
- #######################################################################
-
-+include(GNUInstallDirs)
-+
- # should we build static libs?
- if (MYGUI_STATIC)
- set(MYGUI_LIB_TYPE STATIC)
-@@ -47,7 +49,7 @@ if (UNIX)
- else ()
- configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
- endif ()
-- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
-+ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
- # configure additional packages
-
-diff --git a/CMake/Utils/MyGUIConfigTargets.cmake b/CMake/Utils/MyGUIConfigTargets.cmake
---- a/CMake/Utils/MyGUIConfigTargets.cmake
-+++ b/CMake/Utils/MyGUIConfigTargets.cmake
-@@ -1,6 +1,8 @@
- # Configure settings and install targets
- # FIXME: Copypasted from Ogre and need lots of changes
-
-+include(GNUInstallDirs)
-+
- if (WIN32)
- set(MYGUI_RELEASE_PATH "/Release")
- set(MYGUI_RELWDBG_PATH "/RelWithDebInfo")
-@@ -32,6 +34,12 @@ endif ()
-
- # install targets according to current build type
- function(mygui_install_target TARGETNAME SUFFIX)
-+ install(TARGETS ${TARGETNAME}
-+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}" CONFIGURATIONS Gentoo ""
-+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ FRAMEWORK DESTINATION "${MYGUI_FRAMEWORK_PATH}" CONFIGURATIONS Gentoo ""
-+ )
- install(TARGETS ${TARGETNAME}
- RUNTIME DESTINATION "bin${MYGUI_RELEASE_PATH}" CONFIGURATIONS Release None ""
- LIBRARY DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
-@@ -183,7 +191,13 @@ function(mygui_app PROJECTNAME SOLUTIONFOLDER)
- endif ()
- add_executable(${PROJECTNAME} ${MYGUI_EXEC_TYPE} ${HEADER_FILES} ${SOURCE_FILES})
- endif ()
-- set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+
-+ # rename demo target
-+ if (${SOLUTIONFOLDER} STREQUAL "Demos")
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER} OUTPUT_NAME MYGUI-${PROJECTNAME})
-+ else()
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+ endif()
-
- add_dependencies(${PROJECTNAME} MyGUIEngine Common)
-
diff --git a/dev-games/mygui/files/mygui-3.4.0-underlinking.patch b/dev-games/mygui/files/mygui-3.4.0-underlinking.patch
deleted file mode 100644
index 1dcf2dbbbfda..000000000000
--- a/dev-games/mygui/files/mygui-3.4.0-underlinking.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Fri Jun 15 10:42:42 UTC 2012
-Subject: build system
-
-fix underlinking
-
-diff --git a/MyGUIEngine/CMakeLists.txt b/MyGUIEngine/CMakeLists.txt
---- a/MyGUIEngine/CMakeLists.txt
-+++ b/MyGUIEngine/CMakeLists.txt
-@@ -44,7 +44,10 @@ if (MYGUI_USE_FREETYPE)
- target_link_libraries(${PROJECTNAME}
- ${FREETYPE_LIBRARIES}
- ${ZLIB_LIBRARIES}
-- )
-+ dl)
-+else()
-+ target_link_libraries(${PROJECTNAME}
-+ dl)
- endif()
-
- # platform specific dependencies
diff --git a/dev-games/mygui/mygui-3.4.0.ebuild b/dev-games/mygui/mygui-3.4.0.ebuild
deleted file mode 100644
index ab008898965f..000000000000
--- a/dev-games/mygui/mygui-3.4.0.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_REMOVE_MODULES="yes"
-CMAKE_REMOVE_MODULES_LIST="FindFreetype"
-inherit cmake-utils flag-o-matic multilib
-
-MY_PN=MyGUI
-MY_P=${MY_PN}${PV}
-
-DESCRIPTION="A library for creating GUIs for games and 3D applications"
-HOMEPAGE="http://mygui.info"
-SRC_URI="https://github.com/MyGUI/mygui/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc +ogre opengl plugins samples static-libs test tools l10n_ru"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="ogre? ( !opengl )
- opengl? ( !ogre )"
-
-RDEPEND="media-libs/freetype:2
- sys-libs/zlib
- ogre? (
- dev-games/ogre:0=[freeimage,opengl]
- samples? ( dev-games/ois )
- )
- opengl? (
- virtual/opengl
- media-libs/glew:0=
- )
- tools? ( dev-games/ois )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/mygui-${MY_P}
-STATIC_BUILD=${WORKDIR}/${P}_build_static
-
-PATCHES=(
- "${FILESDIR}"/${P}-underlinking.patch
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${PN}-3.2.2-FHS.patch
-)
-
-pkg_setup() {
- if use samples && use !ogre ; then
- ewarn "Samples disabled, because they only work with ogre!"
- ewarn "Enable ogre USE flag if you want to use samples."
- fi
-}
-
-src_configure() {
- use debug && append-cppflags -DDEBUG
-
- local mycmakeargs=()
-
- # static configuration
- if use static-libs ; then
- mycmakeargs=( -DMYGUI_STATIC=ON
- -DMYGUI_BUILD_DOCS=OFF
- -DMYGUI_INSTALL_DOCS=OFF
- -DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
- -DMYGUI_BUILD_DEMOS=OFF
- -DMYGUI_INSTALL_SAMPLES=OFF
- -DMYGUI_BUILD_TOOLS=OFF
- -DMYGUI_INSTALL_TOOLS=OFF
- -DMYGUI_BUILD_WRAPPER=OFF
- -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
-
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_configure
- unset mycmakeargs
- fi
-
- # main configuration
- mycmakeargs=(
- -DMYGUI_STATIC=OFF
- -DMYGUI_BUILD_DOCS=$(usex doc)
- -DMYGUI_INSTALL_DOCS=$(usex doc)
- -DMYGUI_USE_FREETYPE=ON
- -DMYGUI_BUILD_PLUGINS=$(usex plugins)
- -DMYGUI_BUILD_TOOLS=$(usex tools)
- -DMYGUI_INSTALL_TOOLS=$(usex tools)
- -DMYGUI_USE_SYSTEM_GLEW=$(usex opengl)
- -DMYGUI_BUILD_WRAPPER=OFF
- -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")")
- )
-
- if use ogre && use samples; then
- mycmakeargs+=(
- -DMYGUI_BUILD_DEMOS=ON
- -DMYGUI_INSTALL_SAMPLES=ON
- )
- else
- mycmakeargs+=(
- -DMYGUI_BUILD_DEMOS=OFF
- -DMYGUI_INSTALL_SAMPLES=OFF
- )
-
- fi
-
- if use tools || (use samples && use ogre) ; then
- mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=ON )
- else
- mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=OFF )
- fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- # build system does not support building static and shared at once,
- # run a double build
- if use static-libs ; then
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_compile
- fi
-
- cmake-utils_src_compile
-
- use doc && emake -C "${CMAKE_BUILD_DIR}"/Docs api-docs
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use static-libs ; then
- find "${STATIC_BUILD}" -name "*.a" \! -name "libCommon.a" -exec dolib.a '{}' \;
- insinto /usr/$(get_libdir)/pkgconfig
- doins "${STATIC_BUILD}"/pkgconfig/MYGUIStatic.pc
- fi
-
- if use doc ; then
- dodoc -r "${CMAKE_BUILD_DIR}"/Docs/html/
-
- if use l10n_ru ; then
- docompress -x /usr/share/doc/${PF}/Papers
- dodoc -r Docs/Papers
- fi
- fi
-
- keepdir /etc/MYGUI
- fperms o+w /etc/MYGUI
-
- # test media not needed at runtime
- rm -rf "${ED}"/usr/share/MYGUI/Media/UnitTests || die
- # wrapper not available for linux, remove related media
- rm -rf "${ED}"/usr/share/MYGUI/Media/Wrapper || die
-}
-
-pkg_postinst() {
- elog
- elog "ogre.cfg and Ogre.log are created as"
- elog "${EROOT}/etc/MYGUI/mygui-ogre.cfg and /etc/MYGUI/mygui-Ogre.log"
- elog
-}