summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-01 13:31:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-01 13:48:04 +0200
commitee655b9dd8c278c744b1ec1ec9aa068b257cb6fa (patch)
tree0fbe001fc404f4da29c14c6a8889a36be4c30c99
parentsci-libs/gloo: add 2023.12.03 (diff)
downloadgentoo-ee655b9dd8c278c744b1ec1ec9aa068b257cb6fa.tar.gz
gentoo-ee655b9dd8c278c744b1ec1ec9aa068b257cb6fa.tar.bz2
gentoo-ee655b9dd8c278c744b1ec1ec9aa068b257cb6fa.zip
dev-python/pdm-backend: Fix missing dev-vcs/mercurial test dep
Closes: https://bugs.gentoo.org/931017 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pdm-backend/pdm-backend-2.3.0.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/pdm-backend/pdm-backend-2.3.0.ebuild b/dev-python/pdm-backend/pdm-backend-2.3.0.ebuild
index 6acf66b19a87..68fac1eadef9 100644
--- a/dev-python/pdm-backend/pdm-backend-2.3.0.ebuild
+++ b/dev-python/pdm-backend/pdm-backend-2.3.0.ebuild
@@ -37,6 +37,9 @@ BDEPEND="
test? (
dev-python/setuptools[${PYTHON_USEDEP}]
dev-vcs/git
+ !s390? ( !sparc? (
+ dev-vcs/mercurial
+ ) )
)
"
# setuptools are used to build C extensions
@@ -67,3 +70,13 @@ src_test() {
git config --global user.name "Test User" || die
distutils-r1_src_test
}
+
+python_test() {
+ local args=()
+ if ! has_version dev-vcs/mercurial; then
+ args+=( -k "not [hg" )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest "${args[@]}"
+}