summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-09 16:14:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-09 16:40:18 +0200
commitee7739f996f4763aaf9ec9c18bbee2f5bd255789 (patch)
treeefb07106becbe1c9fd85ff6b15b458bf8c3fef0b
parentdev-cpp/tbb: Stabilize 2021.9.0 arm, #908149 (diff)
downloadgentoo-ee7739f996f4763aaf9ec9c18bbee2f5bd255789.tar.gz
gentoo-ee7739f996f4763aaf9ec9c18bbee2f5bd255789.tar.bz2
gentoo-ee7739f996f4763aaf9ec9c18bbee2f5bd255789.zip
dev-python/ipykernel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.22.0.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index 65804e292881..cfc9dff155da 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,3 +1,2 @@
-DIST ipykernel-6.22.0.tar.gz 151303 BLAKE2B c3567066375099d388c65b43b5b8c8059a823f4185855b6131fd90f42624a71c08d839a3c59c41cf83bb51ec07d0c0487d7bbee573eafa7e7d049dbeff8e59a8 SHA512 e109a2b771ffa40e05416bd925f26a4492c65a44a1acd8100e65ae3e779da9a0eef7222566e79cdcbed4b0fc3224fbd0722728d3fe953b16ab1a14090d0205c2
DIST ipykernel-6.23.0.tar.gz 151969 BLAKE2B c41aac053b27a2e3618831f8d6458b21877b4510062019576fe98f921b9485fe180f2bced09c0a8ddd930af5a386a09d4d13a2ffbb78e58d71bb7a7cea1c91c1 SHA512 d852742bd858639d150864d343da23ee915c2034b8fbad7875755ea580be80b5faf553c16af65c50001f214979cd4a80c89fe08e4db7198754b554de0101a1d1
DIST ipykernel-6.23.1.tar.gz 153370 BLAKE2B 654998d46851bcc55d3c0c9c6134f3fcf8c81c2552d5af6dcdbd791e1ac98ed223a59aafc9b7b4260345f8730d243d3c82d4e19e03935a368a0a0154de547cb0 SHA512 8f3921789c837f7c046eed4ffdaade2273b6491cfd97b9a192a256966a66d58c1ad93cbfa69a5e933e052fa35c2c7a4671a652ee9f2bb2cca5a156c79df0f14f
diff --git a/dev-python/ipykernel/ipykernel-6.22.0.ebuild b/dev-python/ipykernel/ipykernel-6.22.0.ebuild
deleted file mode 100644
index a5c6cc062f22..000000000000
--- a/dev-python/ipykernel/ipykernel-6.22.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi virtualx
-
-DESCRIPTION="IPython Kernel for Jupyter"
-HOMEPAGE="
- https://github.com/ipython/ipykernel/
- https://pypi.org/project/ipykernel/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/comm-0.1.1[${PYTHON_USEDEP}]
- >=dev-python/debugpy-1.6.5[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
- >=dev-python/jupyter-client-8[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-4.12[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
- dev-python/nest_asyncio[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-20[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.4.0[${PYTHON_USEDEP}]
-"
-# RDEPEND seems specifically needed in BDEPEND, at least jupyter
-# bug #816486
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/ipyparallel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- # Use python3 in kernel.json configuration, bug #784764
- sed -i -e '/python3.[0-9]\+/s//python3/' \
- "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
-}
-
-src_test() {
- local EPYTEST_DESELECT=(
- # TODO
- ipykernel/tests/test_debugger.py::test_attach_debug
- ipykernel/tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
- ipykernel/tests/test_debugger.py::test_rich_inspect_at_breakpoint
- ipykernel/tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
- ipykernel/tests/test_debugger.py::test_set_breakpoints
- ipykernel/tests/test_debugger.py::test_stop_on_breakpoint
- ipykernel/tests/test_debugger.py::test_copy_to_globals
- # hangs?
- ipykernel/tests/test_eventloop.py::test_tk_loop
- )
-
- virtx distutils-r1_src_test
-}