summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:21 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:21 +0100
commitee89960c8665621a824df0b1ca142d67d662d2e3 (patch)
tree448a59027ef6282fe257b94ed3798a479ebc2f43
parentsys-libs/suacomp: Port to EAPI 6 (diff)
downloadgentoo-ee89960c.tar.gz
gentoo-ee89960c.tar.bz2
gentoo-ee89960c.zip
sys-libs/suacomp: Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-libs/suacomp/suacomp-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/sys-libs/suacomp/suacomp-9999.ebuild b/sys-libs/suacomp/suacomp-9999.ebuild
index c40821304da1..b356312ab407 100644
--- a/sys-libs/suacomp/suacomp-9999.ebuild
+++ b/sys-libs/suacomp/suacomp-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-inherit toolchain-funcs flag-o-matic git-2
+inherit flag-o-matic toolchain-funcs git-r3
DESCRIPTION="library wrapping the interix lib-c to make it less buggy"
HOMEPAGE="http://suacomp.sf.net"
@@ -11,7 +11,6 @@ EGIT_REPO_URI="https://git.code.sf.net/p/suacomp/git"
LICENSE="BEER-WARE"
SLOT="0"
-KEYWORDS=""
IUSE="debug"
DEPEND=""
@@ -21,9 +20,11 @@ get_opts() {
local shlibc=
local stlibc=
+ local dir
for dir in /usr/lib /usr/lib/x86; do
[[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+ local name
for name in libc.so.5.2 libc.so.3.5; do
[[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
done
@@ -34,7 +35,7 @@ get_opts() {
echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
}
-pkg_setup() {
+src_configure() {
if use debug; then
append-flags -D_DEBUG -D_DEBUG_TRACE
fi
@@ -44,11 +45,6 @@ src_compile() {
emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}"
}
-src_install() {
- emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
- CFLAGS="${CFLAGS}"
-}
-
src_test() {
local v=
@@ -57,3 +53,8 @@ src_test() {
emake check $(get_opts) ${v}
}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
+ CFLAGS="${CFLAGS}"
+}