summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-01 23:43:46 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-02 00:35:47 +0200
commitee8a6c729b7e0d802129ac020fba8b7b212c49f0 (patch)
tree89cdd37fafc5d80461fca1565f555631d8bfac28
parentsys-fs/nilfs-utils: drop 2.2.2-r1 (diff)
downloadgentoo-ee8a6c729b7e0d802129ac020fba8b7b212c49f0.tar.gz
gentoo-ee8a6c729b7e0d802129ac020fba8b7b212c49f0.tar.bz2
gentoo-ee8a6c729b7e0d802129ac020fba8b7b212c49f0.zip
sci-mathematics/why3: bump to 1.6.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/why3/Manifest1
-rw-r--r--sci-mathematics/why3/why3-1.6.0.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/sci-mathematics/why3/Manifest b/sci-mathematics/why3/Manifest
index 4f6bc6bc9f21..636bb81746b6 100644
--- a/sci-mathematics/why3/Manifest
+++ b/sci-mathematics/why3/Manifest
@@ -2,3 +2,4 @@ DIST why3-1.4.0.tar.gz 6306524 BLAKE2B ade7803a608d090ea06d974ae47e920993de92a58
DIST why3-1.4.1.tar.gz 6305011 BLAKE2B 2d916fbf333550f8021bff9e7ccf4ca5685763ca7f82ae133298feaf96f3e8b36290a103fd27224fb6fb2dc36c8d7ad5d93ffc92e8cf7fe1a61abb5a40aecb39 SHA512 7990519179c088be1bc9b5b6d469f6d6fbd683445e20cbf5edd5c97682f2931b2657a92b60e539d7647033bfdc5a63401f28af61fd9b14b41011144afa2016e0
DIST why3-1.5.0.tar.gz 6723500 BLAKE2B e6ae5034cf0b3923dfaa760d604f754d4e385ea92ca1f70c7d4bd9985c75192ed381bb50d7211451f35d485e5c0969b3de4987603720b2fd6609cca5d074b85f SHA512 3ae443733321f2e487d6e503c4dbfe37d0e24c7dbe88eb94a3907775a1e6e30530b58ff835e3b2fff3fac5cd16622d758602e4f2b59aea567c7073199d67888c
DIST why3-1.5.1.tar.gz 6727576 BLAKE2B db88dc011856bc779a917613adb20c14744f5491aba54e424909106a1133362ddf9eb22e4a05660cb3153bfddfa54c488e1f9df046e3c413732924e127975e82 SHA512 1452a21ea9191f57debcc082afe458aec503d6aa24f8bc83f734041cdd302c4f166c9c4fe5f9ec25369b6e83011bdd7b485d67b092efa71ff0c1b39447f4bdac
+DIST why3-1.6.0.tar.gz 6850062 BLAKE2B 91db6f67a9d0fe24b7d7d18e6c5e9cd362563a55702bfb28c478754f53e831beb3033adde251214facd8d64ab923389b0b9fe7b240b6cd09f0b4b3e6f8eca143 SHA512 60d61b8337ab9f2fd2e6c7174eb0bab063f122417738cd75990c5c53120dd535bcedccb670567f5753853d6bc9f8efebb563d079e4d368372a7687193f1346b1
diff --git a/sci-mathematics/why3/why3-1.6.0.ebuild b/sci-mathematics/why3/why3-1.6.0.ebuild
new file mode 100644
index 000000000000..1c3b6b458cc9
--- /dev/null
+++ b/sci-mathematics/why3/why3-1.6.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools findlib
+
+DESCRIPTION="Platform for deductive program verification"
+HOMEPAGE="https://why3.lri.fr/"
+SRC_URI="https://why3.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="coq doc emacs gtk +ocamlopt re sexp stackify +zarith zip"
+
+RDEPEND="
+ !sci-mathematics/why3-for-spark
+ >=dev-lang/ocaml-4.05.0:=[ocamlopt?]
+ >=dev-ml/menhir-20170418:=
+ dev-ml/num:=
+ coq? ( >=sci-mathematics/coq-8.7:= )
+ emacs? ( app-editors/emacs:* )
+ gtk? ( dev-ml/lablgtk:=[sourceview,ocamlopt?] )
+ re? ( dev-ml/re:= )
+ sexp? (
+ dev-ml/ppx_deriving:=[ocamlopt?]
+ dev-ml/ppx_sexp_conv:=[ocamlopt?]
+ dev-ml/sexplib:=[ocamlopt?]
+ )
+ stackify? ( dev-ml/ocamlgraph:=[ocamlopt?] )
+ zarith? ( dev-ml/zarith:= )
+ zip? ( dev-ml/camlzip:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ dev-python/sphinx
+ dev-python/sphinxcontrib-bibtex
+ media-gfx/graphviz
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ )
+"
+
+DOCS=( CHANGES.md README.md )
+
+src_prepare() {
+ mv configure.in configure.ac || die
+
+ sed -i 's/configure\.in/configure.ac/g' Makefile.in || die
+ sed -e '/^lib\/why3[a-z]*\$(EXE):/{n;s/-Wall/$(CFLAGS) $(LDFLAGS)/}' \
+ -e '/^%.o: %.c/{n;s/\$(CC).*-o/$(CC) $(CFLAGS) -o/}' \
+ -e '/\$(SPHINX)/s/ -d doc\/\.doctrees / /' \
+ -i Makefile.in || die
+
+ # remove QA warning about duplicated compressed file:
+ rm examples/mlcfg/basic/why3shapes.gz || die
+
+ eautoreconf
+ default
+}
+
+src_configure() {
+ local -a myconf=(
+ --disable-frama-c
+ --disable-hypothesis-selection
+ --disable-infer
+ --disable-isabelle-libs
+ --disable-pvs-libs
+ --disable-web-ide
+ $(use_enable coq coq-libs)
+ $(use_enable doc)
+ $(use_enable emacs emacs-compilation)
+ $(use_enable gtk ide)
+ $(use_enable ocamlopt native-code)
+ $(use_enable re)
+ $(use_enable sexp pp-sexp)
+ $(use_enable stackify)
+ $(use_enable zarith)
+ $(use_enable zip)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake
+ emake plugins
+
+ use doc && emake doc
+}
+
+src_install(){
+ findlib_src_preinst
+ emake install install-lib DESTDIR="${ED}"
+
+ einstalldocs
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+
+ if use doc; then
+ dodoc doc/latex/manual.pdf
+ dodoc -r doc/html
+ fi
+}