summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 05:24:58 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 05:24:58 +0100
commitee9373246bb2a332ba886735d51c3e1b43f66822 (patch)
tree4ad94bfcd29312c46b0ed6e0da4055b2fb7211ee
parentdev-python/ddt: Bump to 1.7.2 (diff)
downloadgentoo-ee937324.tar.gz
gentoo-ee937324.tar.bz2
gentoo-ee937324.zip
dev-python/sniffio: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sniffio/Manifest1
-rw-r--r--dev-python/sniffio/sniffio-1.3.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sniffio/Manifest b/dev-python/sniffio/Manifest
index 0fe49caaad39..caabc63e039a 100644
--- a/dev-python/sniffio/Manifest
+++ b/dev-python/sniffio/Manifest
@@ -1 +1,2 @@
DIST sniffio-1.3.0.gh.tar.gz 16867 BLAKE2B 44ab59d7477055aeaa0b08983094d8d12493edd5ded6ebd8e1bb048fbb2024325473dc37ebb5f66a10d8275b4e68b8c7f8dfb26088dc30c97a29d9f002fbc667 SHA512 3a9584eea20f5a69958f206fad9f01ef7fc40735f48a6cfaa11ba6eea1e7b8cc8c8053416595fe23276e162b0ab5dd6a41fb30bd9f7994f03b3d3242d5b40ef6
+DIST sniffio-1.3.1.gh.tar.gz 16907 BLAKE2B 9edec11e204f2624d589786744ed2bce6b082fb338c542bf6bddc22a481c9cc97cfd1c5101ae8cad95bf5068ee40d1659aeb420a2f6377377bf9e514e4c49cd1 SHA512 34e2e0a2e1c43e4ce1e1b5cdfb16c4f872897bbc7da77a76b55dc9cae475d87fe1e35d7103cad68ddab93c8be743aaa312ec12b1ddd96ad968be027faa24839f
diff --git a/dev-python/sniffio/sniffio-1.3.1.ebuild b/dev-python/sniffio/sniffio-1.3.1.ebuild
new file mode 100644
index 000000000000..57640b5c7fc1
--- /dev/null
+++ b/dev-python/sniffio/sniffio-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sniff out which async library your code is running under"
+HOMEPAGE="
+ https://github.com/python-trio/sniffio/
+ https://pypi.org/project/sniffio/
+"
+SRC_URI="
+ https://github.com/python-trio/sniffio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+)