summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-04-20 08:13:32 +0300
committerSam James <sam@gentoo.org>2022-06-30 21:40:16 +0000
commitee9dcea0ca6023d17537c1f40a251af9f2e8f839 (patch)
tree2d83bb3da09a1bc89ca9e336d03349a7cd544a11
parentsys-apps/busybox: Enable full version of depmod (diff)
downloadgentoo-ee9dcea0ca6023d17537c1f40a251af9f2e8f839.tar.gz
gentoo-ee9dcea0ca6023d17537c1f40a251af9f2e8f839.tar.bz2
gentoo-ee9dcea0ca6023d17537c1f40a251af9f2e8f839.zip
sys-apps/busybox: Add openrc files for crond
Closes: https://bugs.gentoo.org/751988 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/busybox/busybox-1.34.1-r1.ebuild4
-rw-r--r--sys-apps/busybox/files/crond.confd2
-rw-r--r--sys-apps/busybox/files/crond.initd12
3 files changed, 18 insertions, 0 deletions
diff --git a/sys-apps/busybox/busybox-1.34.1-r1.ebuild b/sys-apps/busybox/busybox-1.34.1-r1.ebuild
index 654edbe4c4b7..80086ac713ca 100644
--- a/sys-apps/busybox/busybox-1.34.1-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.34.1-r1.ebuild
@@ -293,6 +293,10 @@ src_install() {
if busybox_config_enabled ASH && ! use make-symlinks; then
dosym -r /bin/busybox /bin/ash
fi
+ if busybox_config_enabled CROND; then
+ newconfd "${FILESDIR}"/crond.confd busybox-crond
+ newinitd "${FILESDIR}"/crond.initd busybox-crond
+ fi
# bundle up the symlink files for use later
emake DESTDIR="${ED}" install
diff --git a/sys-apps/busybox/files/crond.confd b/sys-apps/busybox/files/crond.confd
new file mode 100644
index 000000000000..707366252913
--- /dev/null
+++ b/sys-apps/busybox/files/crond.confd
@@ -0,0 +1,2 @@
+# Config file for /etc/init.d/busybox-crond
+CRONDARGS=
diff --git a/sys-apps/busybox/files/crond.initd b/sys-apps/busybox/files/crond.initd
new file mode 100644
index 000000000000..e098b14714a4
--- /dev/null
+++ b/sys-apps/busybox/files/crond.initd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/bin/busybox crond"
+command_args="${CRONDARGS}"
+pidfile="/run/crond.pid"
+
+depend() {
+ need clock logger
+ provide cron
+}