summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-01 19:58:08 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-01 19:58:08 +0200
commiteea24a49fbb458c39a3d97b94a2ff29f0c7c8ee2 (patch)
tree47ac34f0d43886b29db645866be72f8079b452ef
parentdev-python/typeguard: Stabilize 4.1.0 arm, #913444 (diff)
downloadgentoo-eea24a49fbb458c39a3d97b94a2ff29f0c7c8ee2.tar.gz
gentoo-eea24a49fbb458c39a3d97b94a2ff29f0c7c8ee2.tar.bz2
gentoo-eea24a49fbb458c39a3d97b94a2ff29f0c7c8ee2.zip
dev-python/pyglet: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-2.0.8.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index d28b47c12000..e533ab22d80d 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,2 +1 @@
-DIST pyglet-2.0.8.gh.tar.gz 6197927 BLAKE2B 7b6f26b0c22fea5da3372ab0a3c71fdc55960452530ea565c2946b39de978fb67e5b4467097ed477ec8eff3a3b5ee5f30f84a31172879c9068821492b4d21bbc SHA512 f8fe20d8e43dcd852e96523e03d0e10fff9a18dd50131e0ddc46a49c981f33b3ea9055c769b87c421e4465c4a98fd5a991a862b37215e1d9eac44ff4d33f4bdf
DIST pyglet-2.0.9.gh.tar.gz 6201289 BLAKE2B 5d79171a1a01087a26a9d02737d6cc1c7bd30d0c7b4266caf211f73a035f26d40495c2aed2090cb4e72b8cd7964b7638c0bd924e0e6bf66db19aecfcac04f455 SHA512 dbaaaa4006b9b92b8d53b5936dc82769c4f2ea203b83fe96952dbfaaba14c1cb877e850c26fb6c1fd4da2580cfc661ff5ea10f30449365dbbfe0307734ba81bd
diff --git a/dev-python/pyglet/pyglet-2.0.8.ebuild b/dev-python/pyglet/pyglet-2.0.8.ebuild
deleted file mode 100644
index aed763e22c21..000000000000
--- a/dev-python/pyglet/pyglet-2.0.8.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Cross-platform windowing and multimedia library for Python"
-HOMEPAGE="
- https://pyglet.org/
- https://github.com/pyglet/pyglet/
- https://pypi.org/project/pyglet/
-"
-SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="examples image +sound"
-
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- media-libs/fontconfig
- )
-"
-RDEPEND="
- virtual/glu
- virtual/opengl
- image? ( || (
- dev-python/pillow[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- ) )
- sound? ( || (
- media-libs/libpulse
- media-libs/openal
- ) )
-"
-# ffmpeg? ( media-libs/avbin-bin )
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- xdg_environment_reset
-
- local EPYTEST_DESELECT=(
- # lacking device/server permissions
- tests/unit/media/test_listener.py::test_openal_listener
- tests/unit/media/test_listener.py::test_pulse_listener
- # fragile to system load
- tests/unit/media/test_player.py::PlayerTestCase::test_pause_resume
- tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
- )
- if [[ ${EPYTHON} == python3.11 ]]; then
- EPYTEST_DESELECT+=(
- # broken test
- # https://github.com/pyglet/pyglet/issues/606
- tests/unit/test_events.py::test_push_handlers_instance
- )
- fi
-
- # Specify path to avoid running interactive tests
- # We could add in integration tests, but they're slow
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}