summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-24 01:50:05 +0100
committerSam James <sam@gentoo.org>2023-07-24 01:50:22 +0100
commiteeb89bb8748fea3cefee84621b15fa6d507cce1e (patch)
tree2fd27eb9f00dfc7eda62523b5eaf16b491c4f4eb
parentsys-process/parallel: stabilize 20230522 for ppc (diff)
downloadgentoo-eeb89bb8748fea3cefee84621b15fa6d507cce1e.tar.gz
gentoo-eeb89bb8748fea3cefee84621b15fa6d507cce1e.tar.bz2
gentoo-eeb89bb8748fea3cefee84621b15fa6d507cce1e.zip
dev-python/numpy: skip 2 more tests on hppa
These two tests are the only failures: * f2py/tests/test_kind.py::TestKind::test_real * f2py/tests/test_kind.py::TestKind::test_quad_precision Both need to be taught about HPPA and its characteristics, so added a comment about how to do that & some past examples. But not a regression either. Bug: https://bugs.gentoo.org/907228 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/numpy/numpy-1.25.1-r2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/numpy/numpy-1.25.1-r2.ebuild b/dev-python/numpy/numpy-1.25.1-r2.ebuild
index 7df5247d4325..a075f702c00c 100644
--- a/dev-python/numpy/numpy-1.25.1-r2.ebuild
+++ b/dev-python/numpy/numpy-1.25.1-r2.ebuild
@@ -113,6 +113,17 @@ python_test() {
)
fi
+ if use hppa ; then
+ EPYTEST_DESELECT+=(
+ # TODO: Get selectedrealkind updated!
+ # bug #907228
+ # https://github.com/numpy/numpy/issues/3424 (https://github.com/numpy/numpy/issues/3424#issuecomment-412369029)
+ # https://github.com/numpy/numpy/pull/21785
+ f2py/tests/test_kind.py::TestKind::test_real
+ f2py/tests/test_kind.py::TestKind::test_quad_precision
+ )
+ fi
+
if [[ $(tc-endian) == "big" ]] ; then
# https://github.com/numpy/numpy/issues/11831 and bug #707116
EPYTEST_DESELECT+=(
@@ -120,7 +131,7 @@ python_test() {
'f2py/tests/test_return_character.py::TestFReturnCharacter::test_all_f90[t1]'
'f2py/tests/test_return_character.py::TestFReturnCharacter::test_all_f90[s1]'
'f2py/tests/test_return_character.py::TestFReturnCharacter::test_all_f77[t1]'
- 'f2py/tests/test_kind.py::TestKind::test_int'
+ f2py/tests/test_kind.py::TestKind::test_int
)
fi