summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-12-31 10:23:36 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-31 10:24:29 +0000
commiteebc4497a89bbd84f11231ef06be92139b866fac (patch)
tree3a84bf92abf94ad75261b23e777155459060685b
parentprofiles/prefix/darwin/macos: drop 10.5 Intel variants (diff)
downloadgentoo-eebc4497.tar.gz
gentoo-eebc4497.tar.bz2
gentoo-eebc4497.zip
app-emulation/dosemu: set default CPP
On autoconf-2.69 CPP detection was missing. Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/762748 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
index 61a15bd1f53c..5700973fde62 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
@@ -90,6 +90,8 @@ src_configure() {
fi
# sndfile support is unconditionally disabled in src/plugin/sndfile/snd_o_wav.c
+ # CPP has to be set explicitly to workaround autoconf-2.69
+ # CPP detection (fixed in 2.70). bug #762748.
econf $(use_with X x) \
$(use_with svga svgalib) \
$(use_enable debug) \
@@ -100,11 +102,12 @@ src_configure() {
--with-fdtarball="${DISTDIR}"/${P_FD}.tgz \
--sysconfdir="${EPREFIX}"/etc/dosemu/ \
--with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
- IA16_LDFLAGS_EXTRA=${nopie_flag}
+ IA16_LDFLAGS_EXTRA=${nopie_flag} \
+ CPP="$(tc-getCPP)"
}
src_compile() {
- # src/makefile.common is fritten manually, uses AR=ar
+ # src/makefile.common is written manually, uses AR=ar
emake AR=$(tc-getAR)
}