summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:24:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:45 +0100
commiteeca34b4804ad5d66fba60c24b30f6f58d97a089 (patch)
treebbde939f781f934227798b6b6710a17aec71d5b8
parentdev-python/rjsmin: Remove old (diff)
downloadgentoo-eeca34b4.tar.gz
gentoo-eeca34b4.tar.bz2
gentoo-eeca34b4.zip
dev-python/rjsmin: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rjsmin/rjsmin-1.2.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/rjsmin/rjsmin-1.2.0-r1.ebuild b/dev-python/rjsmin/rjsmin-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..ef6b0ccf82c9
--- /dev/null
+++ b/dev-python/rjsmin/rjsmin-1.2.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Javascript minifier written in python"
+HOMEPAGE="http://opensource.perlig.de/rjsmin/"
+SRC_URI="
+ https://github.com/ndparker/rjsmin/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest