summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-11-06 21:45:29 +0100
committerAmy Winston <amynka@gentoo.org>2016-11-06 21:45:29 +0100
commiteee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4 (patch)
tree698647c4bd4ff423f0c179df541cc7942fe00c7d
parentsys-kernel/genkernel-next: version bump to 65 (diff)
downloadgentoo-eee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4.tar.gz
gentoo-eee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4.tar.bz2
gentoo-eee8ee8453c9cbdbffa5e6c7ef0a5a4bcfcc18e4.zip
app-misc/khal: version bump 0.8.3 bug #592372
Package-Manager: portage-2.3.0
-rw-r--r--app-misc/khal/Manifest1
-rw-r--r--app-misc/khal/khal-0.8.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/khal/Manifest b/app-misc/khal/Manifest
index c816ae1916f3..466f4e9662e4 100644
--- a/app-misc/khal/Manifest
+++ b/app-misc/khal/Manifest
@@ -1,2 +1,3 @@
DIST khal-0.7.0.tar.gz 109801 SHA256 c6b0c81df56133e4592f02d8e9b60702079da2affd1b09ba96358ccd8eec9402 SHA512 cad0bd8c5e869ffb5333e62747f0c5f71ae4a82adf60889922fcc61b4befefd926b0d642fcb8aec471aafc3fab6f042fa4253d381936c229582a8196319a1505 WHIRLPOOL bd265e0c2ff84014ae7b706722e8b850221458ad4c24dd9137321c06048ed1b5442eb93b7d18338a97f201b6e598bef2be3abe375b80f9530306e2617c73cfbd
DIST khal-0.8.1.tar.gz 125681 SHA256 9d352e4aa6256e493d5aea69540f642158bdcab75d2383e1e43506bf89982094 SHA512 01b24b7fb041a78443eb1ede80797ca689c2141bf6bb6b171f49931de7440055c38efc4611c483fe85da90794d074e4d08224ce633878ca2f7b8d66799391033 WHIRLPOOL cbcff5dec339ea97ee7bc83860b4f0c0f75801553e191d5856d30758c95936b2a156cea09ae9bd5a2ea96a3914b454f84ce0123970d1d74693be75caa23cbd27
+DIST khal-0.8.3.tar.gz 126656 SHA256 1ec6940a9fbd207c41428b103bac1d1555129b9b4eca2b843c544bd48ac63ee3 SHA512 f49e57a6cc9abfcf8dbc5811c2fe00661fd09a8a6d1a64bae4df5ce9c1d01c6f325adeef68a7b45eed3a34bd797b801c00fcd8fa4fdf378335d5273629f0a165 WHIRLPOOL 20963f12d9419f2421680548a6de22261e4d9c4482f6a28937b4339335b5a4965178bae0624cc5172da98c534603d3cd0ed5337e03c04190195a478b34b4a34f
diff --git a/app-misc/khal/khal-0.8.3.ebuild b/app-misc/khal/khal-0.8.3.ebuild
new file mode 100644
index 000000000000..9bda34779305
--- /dev/null
+++ b/app-misc/khal/khal-0.8.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.txt README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+ fi
+}