summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-28 13:12:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-28 13:13:07 +0200
commitef03d6c9f3435b7fe87bb6ed59c1865b67b771ee (patch)
tree016419f3aa34ba8818ef5a595bed6f8bf66823f3
parentdev-python/multidict: Bump to 4.7.6 (diff)
downloadgentoo-ef03d6c9f3435b7fe87bb6ed59c1865b67b771ee.tar.gz
gentoo-ef03d6c9f3435b7fe87bb6ed59c1865b67b771ee.tar.bz2
gentoo-ef03d6c9f3435b7fe87bb6ed59c1865b67b771ee.zip
dev-python/yarl: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/yarl/yarl-1.4.2.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/yarl/yarl-1.4.2.ebuild b/dev-python/yarl/yarl-1.4.2.ebuild
index 029aea2f92fe..6f51bcb5ac23 100644
--- a/dev-python/yarl/yarl-1.4.2.ebuild
+++ b/dev-python/yarl/yarl-1.4.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
@@ -13,15 +13,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/multidict-4.0[${PYTHON_USEDEP}]
>=dev-python/idna-2.0[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${PN}-1.4.2-test-without-coverage.patch
@@ -29,7 +27,3 @@ PATCHES=(
# Upstream: https://github.com/aio-libs/yarl/issues/410
"${FILESDIR}"/${PN}-1.4.2-disable-broken-tests.patch
)
-
-python_test() {
- py.test -v tests || die "Tests fail with ${EPYTHON}"
-}