summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-01 09:14:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-01 09:50:39 +0100
commitef1423b1cb601ab423f76ba5c38ea8ff7acb15f9 (patch)
treef517251798dd18cd809b546f948ecd06949b5a3f
parentapp-admin/system-config-printer: Drop 1.5.13 (diff)
downloadgentoo-ef1423b1.tar.gz
gentoo-ef1423b1.tar.bz2
gentoo-ef1423b1.zip
dev-python/pytz: Bump to 2021.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/pytz-2021.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index 13d5040e6f8e..8cc3cd00a6dd 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1,2 +1,3 @@
DIST pytz-2020.4.tar.gz 310941 BLAKE2B 8abe524ccb7ed676c64dbc129ade5d6562980ea28f8939a3a7a406acf16a8a936e79ff630bf37884610e8936dfe96311ecb752f3b79519a126e1f1ac48883842 SHA512 dcbe763bc6e48c52df855fe03a8109dc0656a0e851324c0468f4307e8aff60e577fe0c9f0b062319e90d2f639b96e98edf8346064705e244143386c863a0aa7c
DIST pytz-2020.5.tar.gz 314194 BLAKE2B c374e0ee803878ad2dde1ef03c108f59f431d645d8067fb9f183b9feb029b4de283477e7f6c146a6d03462bd5cb4fc98118e03601c838f73903f5f7a7d28bf8f SHA512 0845c0b7cefb8732e3016568b17ae73232fe6537bac6da89cb1bf911ba5786ee1be6b5e3aa8767225291e3a7e9afd5b8e40e4051671a3a006f9e2f71c551e13e
+DIST pytz-2021.1.tar.gz 317945 BLAKE2B 5d8b5ac80a9d5be56977df8a422e9f008ccb1afb9468155c53aa97f0bf43ba15c27fd30ee7be035be6fa590dcb272991a069cd1383f1c6c8d378958d7b0c4970 SHA512 507e24e3c5c2c619d9f3c7f4c33d44d262e33656b07701d0db78f5d67b263ad845dccc4ff50e48c580b0f295cf97ed146af7b9259890a50bb6da4c82b70c439b
diff --git a/dev-python/pytz/pytz-2021.1.ebuild b/dev-python/pytz/pytz-2021.1.ebuild
new file mode 100644
index 000000000000..876bb3d8bfa1
--- /dev/null
+++ b/dev-python/pytz/pytz-2021.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="https://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+DEPEND="
+ || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
+RDEPEND="${DEPEND}"
+BDEPEND="app-arch/unzip"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/pytz-2020.5-system-zoneinfo.patch
+)
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}